After two days of installation, strangely my Ubuntu machine is restarting instead of shutdown from both desktop GUI and command line.

sudo shutdown -h now
sudo halt  # (doesn't shutdown, instead freezes on boot screen Plymouth)

I had force shutdown by powering off the machine.

This is not happening all the times.

I have been using Ubuntu for 6 months and never experienced this kind of problem.

  • Please update your question and tell us what command line shutdown options you have tried and also in what way the shutdown does "not work". How do you "force shutdown"? Are you able to shutdown using the desktop GUI menu? Please do not replay in a comment. Update your question as is recommended in the faq. – irrational John May 6 '12 at 22:51
  • Please see this post.askubuntu.com/questions/26601/… – beeju May 7 '12 at 0:56
  • "This is not happening all the times." -> I find that this happens only when the power line is unplugged. – fuenfundachtzig Nov 23 '13 at 10:55
  • I have the same issue on Ubuntu 15.04 on a Lenovo Yoga 2 11. I tried the grub options, but they did not change anything. I found out, that I can get the system to shutdown properly when I attach the external mouse that was attached during installation. After removing the mouse the problem reappears. – user454669 Sep 25 '15 at 18:09

I faced the same issue after I installed Ubuntu 12.04 on a newly built machine. This answer on another post helped me resolve it: https://askubuntu.com/a/135568/40056

Hope that helps.

| improve this answer | |

I had the same issue with new acer aspre v5 notebook. It has been solved by enabling laptop-mode as running

sudo apt-get install laptop-mode-tools
| improve this answer | |
  • Its works, for me after installing laptop-mode-tools and running configuration file from dash. – Fakabbir Amin Nov 15 '15 at 6:33
  • I have same issue on my Intel NUC, this makes my situation worse, my mouse and keyboard are frozen frequently. – kxxoling Aug 28 '16 at 5:36

In my case it was a Wake On Lan motherboard (Gigabyte GA-Z77M-D3H) issue.

My solution:

Install ethtool:

sudo apt-get install ethtool

Set WOL off:

sudo ethtool -s eth0 wol d

If it works, then edit the /etc/rc.local file and add ethtool -s eth0 wol d, before the exit 0 line.

Hope it will help you.

| improve this answer | |
  • I think my problem is related to the WOL but I need to use this functionality, so I don't want to disable it. Any advice? – Felipe Sep 24 '13 at 7:11

Go into your machines BIOS and check for an option called wake-on-lan or something similar and disable it.

This was what caused this problem on my machine.

| improve this answer | |
  • Surprisingly, I found this worked for my case, though I'm not sure why as there should be no WoL packets being sent to the machine. – kiko Nov 26 '15 at 18:41

I have had exactly the same problem on my Acer V5-571G: the laptop shuts down, turns off its power LED, and then starts again after a few seconds. It occurs more often when working on battery.

The problem seems to arise from incorrect work of pm-utils. But if you write on into /sys/bus/*/devices/*/power/control, the kernel takes control over power management at the specified devices - and somehow this makes the hardware to shut down correctly.

So I have written a script:


case "$1" in
  stop) for i in /sys/bus/*/devices/*/power/control ; do echo on > $i ; done 

exit 0

and to make it being executed every time before shutdown I've placed it under name K32power-control-on into /etc/rc0.d directory (don't forget to make the script executable, sudo chmod +x K32power-control-on). After that the laptop shuts down ok.

I think that there are only a few buses/devices which need to have 'on' value written to their power/control, so the list of devices in the script can be restricted, but I just didn't investigate further.

UPD: Here is a more refined solution of the same problem: https://www.behnke.io/fedora-17-on-an-aspire-v5-571-reboot-on-shutdown/

| improve this answer | |

my solution:

  • disable internal wlan adapter
  • buy usb adapter
  • fix shutdown


lspci found rt3290 wlan 
rt3290 use rt2800pci module

blacklist rt2800pci 

edit blacklist.conf

sudo nano /etc/modprobe.d/blacklist.conf

Add the line:

blacklist rt2800pci 

reboot linux

test shutdown :)

install wlan usb adapter RT2870/RT3070 work :)

| improve this answer | |
  • 1
    Why would disabling the wlan fix that the computer doesn't shut down correctly? – Alvar Nov 27 '13 at 23:04
  • My Ralink RT3290 WIFI card also causes the computer to reboot instead of shutting down, but if the card is put in airplane mode then shutdown works as expected. – Enos D'Andrea Dec 14 '19 at 19:12

In my case (Gigabyte H87N-WIFI) I disabled XHCI in BIOS - so I can still use WOL. I suspect a problem with the xhci_hcd kernel module.

| improve this answer | |

I had this problem on a Thinkpad X230 with Ubuntu 12.04, it always rebooted after shutdown when unplugged. I found the solution described here to work for me:

Install laptop-mode-tools (if it's not already installed):

sudo apt-get install laptop-mode-tools

Open grub's config in /etc/default/grub in a text editor and add (or change) this line:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

Update grub using the following command:

sudo update-grub
| improve this answer | |
  • :( it didn't worked for me. And even more, my wifi, lcd brightness and other functions in my laptop stop working. – lepe Nov 29 '14 at 3:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.