1

Why are my network shares from Ubuntu 18.04 LTS computers listed twice and with a (File Sharing) suffix? How do I get networked computers to be listed just once and without the (File Sharing) suffix?

I have 3 computers with Ubuntu 16.04 (AMD, Hackintosh, Garage), 2 with Ubuntu 18.04 (LenovoT61, LenovoX201), and 1 Netgear R7000 router with factory firmware (R7000). I'm used to Ubuntu 16.04 and have just recently installed Ubuntu 18.04 on two Lenovo laptops (LenovoT61, LenovoX201).

I've setup all the computers using Samba, that is, I am NOT using that new Nautilus-Samba share feature. On all the computers, I am sharing the ~/Downloads/ folder and this is setup samba using the gui-based Samba Server Configuration Tool 1.2.63. All computers are on the same workgroup. The /etc/samba/smb.conf file for the LenovoT61, for example, shows at the bottom of the file:

[Downloads]
    path = /home/feipoa/Downloads
    writeable = yes
;   browseable = yes
    valid users = feipoa

There is only one user, feipoa, for all the computers. The router's network share (R7000) is for guest and doesn't need a user/password. Now when I view the "Other Locations - Network" in Nautilus, or "Browse Network" entries with Caja, I see:

R7000
AMD
Hackintosh
Garage
Lenovo61 (File Sharing)
Lenovo61 (File Sharing)
LenovoX201 (File Sharing)
Lenovo201 (File Sharing)

Clearly the Lenovo T61 and Lenovo X201 (using Ubuntu 18.04) appear differently than those computers using Ubuntu 16.04 - the entries appear twice and have this (File Sharing) suffix added after the computer name. How do I have these shares listed only once and without the (File Sharing) suffix?

When I click on each of those two T61 entries, for example,

the first goes to -----> smb://lenovot61/
the second goes to ----> smb://lenovot61.local/

The Ubuntu 16.04 computers (AMD, HACKINTOSH, GARAGE) don't list the .local/ option. Any idea how to get rid of the .local share option and the (File Sharing) suffix?

0

Any idea how to get rid of the .local share option and the (File Sharing) suffix?

A modern Samba server will anounce itself to the rest of the network using two different methods:

[1] The old NetBIOS method ( lenovot61 - for example )

[2] The mDNS ( Avahi ) method ( lenovot61.local )

You can on the 18.04 machines disable either one of them or both if you want by adding a line in /etc/samba/smb.conf - under the workgroup = WORKGROUP line.

To disable NetBIOS the line is: disable netbios = yes

To disable mDNS the line is: multicast dns register = no

Then restart smbd on the server: sudo service smbd restart

Sometimes you may need to reboot the server.

1
  • Thank you Morbius1. Your solution resolved the issue. – feipoa Apr 3 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.