0

I have typical home LAN, with a Ubuntu desktop and Windows 10 desktop both on same LAN. I'm trying to get VNC access from the Windows machine to control the desktop of Ubuntu computer (Ubuntu 18.04 normal desktop installation). I keep getting a connection refused message when using VNC Viewer on the Windows machine.

I followed the instructions to enable screen sharing from the ubuntu systems menu, tried both the required password and the ask for access option. And the on switches for sharing and for the ethernet network is on. ss -lnt shows the port is opened: ''' LISTEN 0 5 [::1]:5900 [::]:* ''' On the Real VNC viewer side, I have the correct IP address and port is 5900. I'm able to VNC into my raspberry pi, and I'm able to ssh from the windows machine into the Ubuntu machine. No luck with VNC.

In the VNC viewer settings, I've tried adding port number to IP, like this 192.168.1.178:5900, and I've tried adding a :1 instead of port for desktop number. I've also tried just plane IP address. None of that has worked.

VNC Viewer setting:

enter image description here

Connection refused error:

enter image description here

Reference:

https://linuxconfig.org/ubuntu-remote-desktop-18-04-bionic-beaver-linux

2
  • Is any firewall running in the Ubuntu computer? If so what is the firewall settings? Please add these information in your question
    – user68186
    Mar 31, 2021 at 21:16
  • 3
    Your ss command output seems to show the service listening on the IPv6 interface, however you appear to be trying to connect via IPv4. Are you sure it is actually listening on the IPv4 interface as well? Mar 31, 2021 at 22:24

1 Answer 1

0

You can check/confirm the port address by using command

sudo netstat -plutn

Its a VERY useful command. I do not have a link for this - saw it on stackoverflow or askubuntu . Sorry

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.