0

I'm on ubuntu 18.04 and I was trying to get sound to output from the monitor, through the HDMI connection on my nvidia graphic card. I searched for many methods, however none of them worked. I must have done something really stupid during the process and now the original Built-in Audio Analog Stereo output device (which worked perfectly well before) is simply missing.

I'm pretty desperate right now so please help: In my settings page, there is only one device corresponding to the graphic card, which does not work: enter image description here

I used to see something like "Built-in Audio Analog Stereo", but now it is missing.

In Alsamixer, there is only one card as well: enter image description here

In pavucontrol, there used to be 2 output devices, one is the graphic card, the other is for the build-in headphone/speaker, something like "Analog Stereo Out". Now it is missing: enter image description here

below is a history of the commands I executed while I was messing with it. I'm not sure which caused the build-in output missing: maybe some configuration file I editted was relevant?

   79  sudo reboot 
   80  exit
   81  fcitx-configtool
   82  sudo apt-get install pavucontrol
   83  pavucontrol
   84  speaker-test --channels 2 --rate 48000 --device hw:0,3
   85  alsamixer
   86  sudo alsa force-reload
   87  sudo apt-get remove --purge alsa-base
   88  sudo apt-get remove --purge pulseaudio
   89  sudo apt-get install alsa-base
   90  sudo apt-get install pulseaudio
   91  sudo alsa force-reload
   92  sudo reboot 
   93  alsamixer
   94  sudo lspci -H1| grep -i audio
   95  ls
   96  cd Documents/
   97  sudo lspci -H1| grep -i audio
   98  git clone git://github.com/hhfeuer/nvhda.git
   99  sudo apt install git
  100  sudo apt-get update
  101  sudo apt install git
  102  git clone git://github.com/hhfeuer/nvhda.git
  103  cd nvhda/
  104  make
  105  sudo make install 
  106  sudo modprobe nvhda
  107  sudo tee /proc/acpi/nvhda <<<ON
  108  sudo gedit /etc/modules
  109  pavucontrol
  110  sudo alsamixer
  111  sudo apt-get install pavucontrol
  112  sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf
  113  sudo alsamixer
  114  pavucontrol
  115  sudo reboot
  116  history 
  117  sudo gedit /etc/modules
  118  sudo tee /proc/acpi/nvhda <<<ON
  119  sudo tee /proc/acpi/nvhda <<<OFF
  120  pavucontrol
  121  sudo reboot 

I don't even want to output sound thru HDMI anymore. I just want the original built-in audio output device back...

6
  • On the first graphic near the bottom look at the selected profile. It is set to HDMI. The 4 Th graphic is correct you have selected this as the output in the 2 ND graphic. Change that and you should be ok.
    – David
    Mar 31, 2021 at 15:40
  • @David nope the selected profile can not be changed, since it has ONLY one option - the current one. Mar 31, 2021 at 15:44
  • Did you take away any HDMI cables other then the needed one for the video monitor?
    – David
    Mar 31, 2021 at 15:51
  • @David No. I am suspecting I turned off the built-in sound card in BIOS settings back then... There is no other way that the original built-in device is gone. Right? Mar 31, 2021 at 15:53
  • No idea I do not know what the BIOS in your computer supports.
    – David
    Mar 31, 2021 at 15:54

0

You must log in to answer this question.

Browse other questions tagged .