I'm new to Ubuntu. I've installed Ubuntu 12.04 on a USB flash drive. It boots fine from the USB stick. But if I remove it and boot again, Window 7 should boot. Well it doesn't. Seems like the hard disk is not there any more. Must have done something wrong while installing Ubuntu. My laptop is an Acer Aspire 1410 without a DVD reader. The USB flash drive is a 64G Sandisk Cruzer. I've check in the Bios and it still see the hard drive. When I'm on Ubuntu I'm also unable to see my local hard disk.

How can I solve this problem?

  • Not a dupe of that one, the OP want their Windows on the internal disk back. Try with a Windows CD recovery: askubuntu.com/questions/17493/…
    – Takkat
    May 6, 2012 at 19:12
  • well what is the error your are getting instead of window 7 starting?
    – ashutosh
    May 6, 2012 at 19:41

4 Answers 4


If the above answer doesn't pan out, you might try to boot from a different device by using whatever the boot option is in your BIOS (probably F11 or F9) and pointing it directly to where Windows is installed.


Your question is not too clear, but I suggest you put back the USB drive and boot up to the Grub menu. As soon as it appears, press the spacebar to stop the timer. Now examine the Grub boot menu and see if you have a line mentioning Windows. If so, boot into Windows, and then download a little program called, EasyBCD. This is a free program for Windows which allows you to adjust the boot sequence. If that doesn't work, create a bootable CD from Super Grub Boot Disc. Boot from that and you will see all the OSs installed on your Hard Disc. You can choose one of them to boot and then go on to solve the initial problem. Don't be afraid to ask again. Good luck.

  • Tks Sun Dial, I'll try to create a bootable CD but it will have to be on another USB stick since I don't have any CD drive on this PC. By the way, Grub doesn't show at boot, it goes directly into Ubuntu asking my password.
    – lightray
    May 6, 2012 at 19:28
  • That suggest that the timeout for the Grub menu is zero seconds. If you get Ubuntu running, you can set a timeout of say 10 seconds with Grub Customizer by Daniel Richter; you'd need to install it.
    – Sun Dial
    May 6, 2012 at 19:34

Maybe the wrong disk is marked as the startup disk.

Create an rBoot disc (download from tonymac forum), boot from the disc and get into Windows.

Open Disk Utility and from there, mark the System Reserved partition as bootable.

If that doesn't work, mark the Windows partition as bootable (most probably the C: drive).


You forgot to select the bootloader's initial install disk, this is easily fixed however.

1) Boot into ubuntu and type the following:

sudo grub-install /dev/sdb Note: Ensure the the thumbdrive is indeed /dev/sdb through disk manager in Ubuntu. This will put the bootloader pointer for the BIOS onto the thumbdrive.

sudo update-grub will update grub's list of OS' just to be sure.

2) Reboot into grub. You should be presented with an aubergine menu with entries that looks like

Ubuntu 12.04, with linux x.x.x

Ubuntu 12.04, with linux x.x.x, recovery


Memtestx86, serial output xx

Windows 7 on /dev/sda1 (Loader)

Select the windows entry, while hammering F8. When a second (black, grey and white) list comes up, select repair your computer.

Just to be sure, remove the thumbdrive at this point.

Select your windows installation if prompted, and select the first option if given a list of icons with descriptions. This will restore the Windows Bootloader pointer, and allow Windows to boot. (This system assumes windows can't boot and checks things to make sure it can.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.