I'm using a Netgear WN311B PCI wireless adapter on my desktop. The device works without problems under Windows (dual boot).

I have enabled the Broadcom STA wireless drivers in "Additional Drivers".

This is the output of /etc/log/syslog when I enable wireless in the Wicd dialog:

May  6 16:50:41 cosine NetworkManager[816]: <info> WiFi now enabled by radio killswitch
May  6 16:50:41 cosine NetworkManager[816]: <info> (eth2): bringing up device.
May  6 16:50:41 cosine wpa_supplicant[2693]: nl80211: 'nl80211' generic netlink not found
May  6 16:50:41 cosine NetworkManager[816]: <info> (eth2): supplicant interface state: starting -> ready
May  6 16:50:41 cosine NetworkManager[816]: <info> (eth2): device state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
May  6 16:50:41 cosine NetworkManager[816]: <info> (eth2): supplicant interface state: ready -> inactive
May  6 16:50:41 cosine NetworkManager[816]: <warn> Trying to remove a non-existant call id.
May  6 16:50:42 cosine avahi-daemon[795]: Joining mDNS multicast group on interface eth2.IPv6 with address fe80::21f:33ff:feb3:b184.
May  6 16:50:42 cosine avahi-daemon[795]: New relevant interface eth2.IPv6 for mDNS.
May  6 16:50:42 cosine avahi-daemon[795]: Registering new address record for fe80::21f:33ff:feb3:b184 on eth2.*.

This is the result when I run "sudo iwlist eth2 scan": eth2 No scan results

This is the output of lsmod:

Module                  Size  Used by                                                                                                                                                                                                         
wl                   2568210  0                                                                                                                                                                                                               
nvidia              12319264  40                                                                                                                                                                                                              
rfcomm                 47604  0                                                                                                                                                                                                               
snd_hda_codec_via      51398  1                                                                                                                                                                                                               
bnep                   18281  2                                                                                                                                                                                                               
bluetooth             180104  10 rfcomm,bnep                                                                                                                                                                                                  
parport_pc             32866  0                                                                                                                                                                                                               
snd_hda_intel          33773  3                                                                                                                                                                                                               
ppdev                  17113  0                                                                                                                                                                                                               
snd_hda_codec         127706  2 snd_hda_codec_via,snd_hda_intel                                                                                                                                                                               
lib80211_crypt_tkip    17390  0                                                                                                                                                                                                               
snd_usb_audio         122982  1                                                                                                                                                                                                               
snd_pcm                97188  3 snd_hda_intel,snd_hda_codec,snd_usb_audio                                                                                                                                                                     
uvcvideo               72627  0                                                                                                                                                                                                               
videodev               98259  1 uvcvideo                                                                                                                                                                                                      
snd_hwdep              13668  2 snd_hda_codec,snd_usb_audio                                                                                                                                                                                   
snd_usbmidi_lib        25395  1 snd_usb_audio                                                                                                                                                                                                 
psmouse                87692  0                                                                                                                                                                                                               
v4l2_compat_ioctl32    17128  1 videodev                                                                                                                                                                                                      
snd_seq_midi           13324  0                                                                                                                                                                                                               
snd_rawmidi            30748  2 snd_usbmidi_lib,snd_seq_midi                                                                                                                                                                                  
joydev                 17693  0 
lib80211               14381  2 wl,lib80211_crypt_tkip
snd_seq_midi_event     14899  1 snd_seq_midi
serio_raw              13211  0 
snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
asus_atk0110           18078  0 
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    78855  19             snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
mac_hid                13253  0 
lp                     17799  0 
parport                46562  3 parport_pc,ppdev,lp
vesafb                 13844  1 
r8169                  62099  0 
usbhid                 47199  0 
hid                    99559  1 usbhid

This is the output of "sudo lshw -C network":

   description: Ethernet interface
   product: RTL8111/8168B PCI Express Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth0
   version: 02
   serial: 48:5b:39:d1:74:b4
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip= latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
   resources: irq:44 ioport:e800(size=256) memory:f8eff000-f8efffff memory:f8ee0000-f8eeffff memory:feaf0000-feafffff
   description: Wireless interface
   product: BCM4321 802.11b/g/n
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: eth2
   version: 01
   serial: 00:1f:33:b3:b1:84
   width: 32 bits
   clock: 33MHz
   capabilities: bus_master ethernet physical wireless
   configuration: broadcast=yes driver=wl0 driverversion= latency=64   multicast=yes wireless=IEEE 802.11bgn
   resources: irq:16 memory:febfc000-febfffff

I'm at a loss. I've tried using wicd, without results. I've tried removing and reinstalling the card. I've tried removing the driver and modprobing it. I've tried disabling the STA driver.

What am I doing wrong?


I have had this same problem for a while with my laptop. Upon installation I have to connect with wired connection and uninstall the broadcom sta drivers and install the b43-fwcutter package instead. You also need the firmware-b43-installer package. It is possible to download the packages and dependencies and install them manually, but I have had much better luck installing with through the wired adapter.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.