4

After a fresh install of Ubuntu 20.04 LTS on my new Razer Blade 15 Advanced Model (Early 2021) - RZ09-036, I am unable to use Wifi or Bluetooth. It's a common problem as here. Wifi and Bluetooth settings are just flickering and are unresponsible. 

I have tried cold booting, installing new firmware, following this post,  and nothing that I could find online solved my issue.

Please see a linked screenshot of error messages when shutting down the laptop. In case you need any more information, please let me know.

Screenshots of error messages on my post Intel community forum

Can someone help with this issue, for me, it's critical that I can establish a normal workflow on this laptop on Ubuntu (can also be any other version if it's going to work).

EDIT: 1

[   73.765733] Bluetooth: hci0: Reading Intel version information failed (-22)
[   73.765743] Bluetooth: hci0: Intel Read version failed (-22)
[   73.765844] Bluetooth: hci0: Intel reset sent to retry FW download
[   74.365767] Bluetooth: hci0: Reading Intel version information failed (-22)
[   74.365776] Bluetooth: hci0: Intel Read version failed (-22)
[   74.365885] Bluetooth: hci0: Intel reset sent to retry FW download
[   74.964725] Bluetooth: hci0: Reading Intel version information failed (-22)
[   74.964734] Bluetooth: hci0: Intel Read version failed (-22)
[   74.964829] Bluetooth: hci0: Intel reset sent to retry FW download
[   75.561751] Bluetooth: hci0: Reading Intel version information failed (-22)
[   75.561759] Bluetooth: hci0: Intel Read version failed (-22)
[   75.561840] Bluetooth: hci0: Intel reset sent to retry FW download
[   76.161701] Bluetooth: hci0: Reading Intel version information failed (-22)
[   76.161710] Bluetooth: hci0: Intel Read version failed (-22)
[   76.161820] Bluetooth: hci0: Intel reset sent to retry FW download
[   76.759799] Bluetooth: hci0: Reading Intel version information failed (-22)
[   76.759806] Bluetooth: hci0: Intel Read version failed (-22)

...
...
... it continues ...

EDIT 2:

user@Razer-LT:~$ lspci -nnk | grep 0280 -A3
03:00.0 Network controller [0280]: Intel Corporation Device 
[8086:2725] (rev 1a)
Subsystem: Intel Corporation Device [8086:0024]
Kernel modules: iwlwifi
04:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983 [144d:a808]

I've also tried on Ubuntu 20.10 and I got the same issue. For now, I managed to get an Internet connection by using USB-c to LAN adapter.

Iam using this kernel:

user@Razer-LT:~$ uname -r
5.8.0-48-generic

FINAL SOLUTION: Update the kernel to 5.10.

Keep in mind that I've decided to wait and rather used an external Wifi-adapter, Bluetooth transmitter, duo to possible brakes of a system.

2
  • 1
    Does this answer your question? WiFi Intel AX210NGW is not recognized. If not specifically, follow the same troubleshooting process to identify and search for your exact chipset.
    – user535733
    Mar 26 at 21:46
  • Can you open a terminal and show us the output of dmesg | grep -i blu by editing your post and adding the TEXT to the bottom (no screenshots please). Mar 26 at 23:29
4

As is stated quite clearly on the firmware link you posted in your question, the Intel® Wi-Fi 6E AX210 is supported since kernel 5.10 as according to your uname output you are running 5.08 the Intel® Wi-Fi 6E AX210 isn't supported by your kernel version. The Linux 5.10 kernel (or later) will ship as part of Ubuntu 21.04 in April. This version will also get backported to Ubuntu 20.04 LTS at a later date. It's possible to manually install a mainline kernel in Ubuntu however if it breaks you get the pieces. Having entertained that warning, if you still can't wait and want to attempt to install kernel 5.10 or later you should review this answer.

3
  • 1
    After connecting all dots together as you stated, I see clearly now your answer as a solution. Personally, I've decided to wait, my workflow depends for now on 20.04 LTS. I will update this thread once I test and try the new Ubuntu version with kernel 5.10. Thank you for your reply! Mar 28 at 9:29
  • @SašoPavlič Always glad to help.
    – Elder Geek
    Apr 2 at 12:47
  • 1
    I've just tested it on the new Ubuntu version 21.04 (Kernel 5.11) Bluetooth and Wifi is working normally. Apr 23 at 8:35
2

I actually managed to make the AX210 run in Ubuntu 18.04 LTS with Linux Kernel 4.15! Here's what I did:

  1. Install the "backport-iwlwifi-dkms" package (sudo apt install backport-iwlwifi-dkms)
  2. Unfortunately, the iwlwifi sources in this package are too old and only support pre-production AX210, so:
  3. Grab the up-to-date backport-iwlwifi sources from Intel's github repository: git clone https://github.com/intel/backport-iwlwifi.git
  4. Now go to /usr/src, there's a subdirectory with the old sources from step 1 there (backport-iwlwifi-7906)
  5. Copy the new sources to a new directory, e.g. sudo cp -a /whereever/you/cloned/to/backport-iwlwifi/iwlwifi-stack-dev backport-iwlwifi-8000
  6. Copy the file "dkms.conf" from the old sources directory to the new sources directory and edit the second line to change the PACKAGE_VERSION from 7906 to 8000
  7. Remove the bad dkms module that was installed with the package in step 1: sudo dkms remove backport-iwlwifi/7906 --all
  8. Add the updated dkms module with the version just created: sudo dkms add backport-iwlwifi/8000
  9. Build and install the updated dkms modules: sudo dkms install backport-iwlwifi/8000

Now the driver is ready, but you still need to get the firmware for the chip:

  1. Clone the linux-firmware repository: git clone https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
  2. Pick out the firmware files you need and copy them to /lib/firmware. If you're not sure which firmware you need, just boot with the new driver and check dmesg for messages from iwl: dmesg | grep iwl - the firmware files it was looking for will be named there.
  3. PITFALL: The AX210 also needs an additional "pnvm" file, which is also found in the repository, but not quite well mentioned by the driver. If it is missing, it'll spray a ton of error messages.

For my Intel AX210 module, I ended up adding these files to /lib/firmware:

-rw-r--r-- 1 root root 1413868 Jun  3 18:27 iwlwifi-ty-a0-gf-a0-59.ucode
-rw-r--r-- 1 root root 1455104 Jun  3 18:27 iwlwifi-ty-a0-gf-a0-62.ucode
-rw-r--r-- 1 root root 1460012 Jun  3 18:27 iwlwifi-ty-a0-gf-a0-63.ucode
-rw-r--r-- 1 root root   27456 Jun  3 18:46 iwlwifi-ty-a0-gf-a0.pnvm

And it is up and running!

2
  • Great answer! I hope it finds out people struggling with this. Jun 5 at 10:22
  • At the current time, backport-iwlwifi-dkms seems to have been upgraded beyond the 8000-version. But it refuses to install in my current state of Ubuntu 20.04.3 on my Lenovo ThinkPad P14s. This simple solution worked for me instead: askubuntu.com/a/1360291/26834 Oct 12 at 11:36
0

I had the same issue on ubuntu 20.04 with my razer blade 15 2021 as well. I tested you solution and updated the kernel to 5.11.16 using the Ubuntu Mainline Kernel Installer, https://ubuntuhandbook.org/index.php/2020/08/mainline-install-latest-kernel-ubuntu-linux-mint/

I had to deactivate "safe boot" in the bios since ubuntu was unwilling to boot using this unsigned kernel

1
  • Glad that we are finding solutions together! At the moment you can peacefully just install Ubuntu 21.04 on the Razer blade 15 2021, which has a 5.11 kernel. But keep in mind majority of ML tools (if you need them) are yet not supporting it (Cuda, cuDNN, and probably some others) Apr 24 at 10:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.