0

While performing an desktop upgrade from a freshly-updated 18.04 to 20.04.2, a problem was reported related to the tex-common package. The upgrade seems to run ok except that the software updater always reports the problem, e.g.:

update-initramfs: Generating /boot/initrd.img-5.4.0-70-generic
Errors were encountered while processing:
 tex-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up tex-common (6.13) ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Building format(s) --all.
    This may take some time... 
fmtutil failed. Output has been stored in
/tmp/fmtutil.CLS3AAW1

I ran dpkg -C and got:

The following packages are only half configured, probably due to problems
configuring them the first time.  The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 tex-common           common infrastructure for building and installing TeX

So I tried dpkg --configure tex-common and, with the exception of the extension on the output file, the report was a duplicate of the one above.

The output file ends with:

fmtutil [ERROR]: running `pdftex -ini   -jobname=pdfjadetex -progname=pdfjadetex *pdfjadetex.ini </dev/null' return status: 1
fmtutil [ERROR]: returning error due to option --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=jadetex -progname=jadetex *jadetex.ini </dev/null' return status: 1
fmtutil [ERROR]: returning error due to option --strict
fmtutil [INFO]: successfully rebuilt formats: 12
fmtutil [INFO]: failed to build: 2 (pdftex/pdfjadetex pdftex/jadetex)
fmtutil [INFO]: total formats: 14
fmtutil [INFO]: exiting with status 2

The entire file can be seen at https://www.dropbox.com/s/vz5u6lvkpxy0l9d/fmtutil.CLS3AAW1?dl=0

I have 3 other machines running 20.04.2, two of which were also upgrades from 18.04, and this problem did not occur on any of them, so it doesn't seem likely to me that it's a dpkg bug. Do I have any alternatives other than a clean reinstallation of 20.04.2?

5

1 Answer 1

0

packages.ubuntu.com/search?keywords=jadetex suggests you need package texlive-formats-extra. Same for pdfjadetex. I wouldn't know why one system fails and not the others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.