2

Here's what my favorites bar (only shows on the applications panel) looks like this without Ubuntu dock enabled:

No trash icon, dock disabled

But when I enable Ubuntu dock, here's what my favorites bar looks like

Trash icon when dock is enabled

If I right click on the trash icon I cannot remove it.

If I run a command to list all the apps on the favorites bar, the trash icon is not in the list

No trash icon in list of apps that are in the favorites bar No trash icon in list of apps that are in the favorites bar

How could I go about the minor issue of removing this trash icon?

Here's my system info if it helps any:

            .-/+oossssoo+/-.               kudos@kudos-Swift-SF314-42 
        `:+ssssssssssssssssss+:`           -------------------------- 
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 20.04.2 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Host: Swift SF314-42 V1.09 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 5.8.0-48-generic 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 33 mins 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 1604 (dpkg), 15 (snap) 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: zsh 5.8 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 1920x1080 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: GNOME 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: Mutter 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   WM Theme: Adwaita 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Theme: WhiteSur-light [GTK2/3] 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Icons: BigSur [GTK2/3] 
  +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal: HyperTerm 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      Terminal Font: MesloLGS NF 
    .ossssssssssssssssssdMMMNysssso.       CPU: AMD Ryzen 5 4500U with Radeon Graphics (6) @ 2.375GHz 
      -+sssssssssssssssssyyyssss+-         GPU: AMD ATI 03:00.0 Renoir 
        `:+ssssssssssssssssss+:`           Memory: 1868MiB / 7387MiB 
            .-/+oossssoo+/-.
                                                                   
                                                                   

3

It seems, somehow you have enabled the below key to true, either by installing dash-to-dock extension or changing the values in dconf-editor.

to know the key value, run below command.

gsettings get org.gnome.shell.extensions.dash-to-dock show-trash

Probably it gives true because your trash icon is visible when you turn on this extension (ubuntu-dock).

set the value to false with below command.

gsettings set org.gnome.shell.extensions.dash-to-dock show-trash false

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.