3

I'm on Ubuntu 20.04 and I really am a beginner on Linux.

The problem: Every tabs opened on firefox are blank

When: Every time : the welcoming page is blank and when i try to open a bookmark, type an URL, open in another tab, in private mode (it's just a purple page) i only have blank tabs. Extensions pop-ups are empty and the configuration pages from the burger menu do not open. The only not-blank tab i can open is the troubleshooting information's page

What I tried: I obviously tried to restart my computer, to check my internet connection. I did refresh firefox, restart with add-ons disabled and clear startup cache. I changed my mozilla profile to a new. I tried to uninstall/reinstall firefox this way:

sudo apt-get purge firefox
sudo rm -Rf /etc/firefox/
sudo rm -Rf /usr/lib/firefox*

It didn't work, so I tried this other way to uninstall but it didn't work.

sudo apt-get purge firefox firefox-globalmenu firefox-gnome-support

E: Impossible de trouver le paquet firefox-globalmenu
E: Impossible de trouver le paquet firefox-gnome-support

My conclusion is then that the firefox's files are not the problem but that firefox may use a third party file corrupted

Before this happened I followed a guide to install Citrix and ICAClient to use a distant computer, and used these commands

sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/
sudo c_rehash /opt/Citrix/ICAClient/keystore/cacerts/

So it might come from the ca-certificates files having been altered ? My question then is where do you think it might come from and what can I do, where should I look at ?

Thank you so much for reading this to the end and even more if you take time to answer.

1
5

I had a similar problem today, Firefox works perfectly then I installed Citrix Workspace via .deb file, tried to connect with ica file on Citrix and blank pages on FF.

Nothing with uninstall, install other version, new profile, just like you.

What works for me :

I removed Citrix:

sudo apt-get --purge remove -y icaclient

Then I downloaded tar.gz instead of .deb file, followed instructions on :

Citrix Documentation Website

Section : "Install using a tarball package"

It work fine now for me.

Hope it helps

3
  • I had the exact same problem with Firefox on Ubuntu 21.04. Always the message [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost. I tested to downgrade firefox, try Nightly, installing/removing lots of packages, opening it on a new user... nothing to do. But your solution worked perfectly ! I just un-installed the icaclient_21.4.0.11_amd64.deb. You just saved my day.
    – jomuller
    May 17 at 20:20
  • The problem is also related here : askubuntu.com/a/1327931/558294 . For my part, I was able to use citrix after reinstallation of the critix workspace without selecting the protection application components. Also work in a virtual machine.
    – jomuller
    May 19 at 8:10
  • I've tried this answer 1st and it works! If I'd seen @jomuller's comment I'd have tried that first. Looks like it's a Citrix problem not Firefox.
    – alle_meije
    Jun 14 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.