4

I have just installed Ubuntu 20.04 on a new build with the following hardware:

  • CPU: Intel i5-10400
  • Integrated Graphics: Intel UHD 630
  • Motherboard: ASRock h510m-ITX/ac
  • RAM: Corsair LPX Vengeance 16GB 2666MHz
  • SSD: Crucial P2 500GB

I have been unable to get any graphics output to work unless I add nomodeset to my kernel parameters - whenever it boots up the screen simply turns off after the ASRock logo, and does not respond to any keyboard input (I can't even switch to a tty).

This includes on the Live USB installer, which I had to run in "safe graphics" mode to install. I have also tried the 20.10 Live USB, and even Manjaro (GNOME 20.2.1), both of which had the same issue.

If I use nomodeset then Ubuntu boots normally, but I believe this disables any hardware acceleration, and I'm unable to change the display resolution, so I am looking for a proper fix.

Checking the journal (I can log in via SSH) I see that GDM fails to start:

Mar 21 15:20:32 colin-desktop gnome-shell[901]: Failed to create backend: No GPUs with outputs found
Mar 21 15:20:32 colin-desktop gnome-session[830]: gnome-session-binary[830]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 21 15:20:32 colin-desktop gnome-session-binary[830]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 21 15:20:32 colin-desktop gnome-session-binary[830]: Unrecoverable failure in required component org.gnome.Shell.desktop
Mar 21 15:20:32 colin-desktop gdm-launch-environment][803]: pam_unix(gdm-launch-environment:session): session closed for user gdm
Mar 21 15:20:32 colin-desktop gdm3[781]: GdmDisplay: Session never registered, failing

And that the Xorg server exits, with error messages from /var/lib/gdm3/.local/share/xorg/Xorg.0.log:

[     9.404] (EE) modeset(0): No modes.
[     9.406] (EE) Screen(s) found, but none have a usable configuration.
[     9.406] (EE)
[     9.406] (EE) no screens found(EE)
[     9.406] (EE)
[     9.406] (EE) Please also check the log file at "/var/lib/gdm3/.local/share/xorg/Xorg.0.log" for additional information.
[     9.406] (EE)
[     9.407] (EE) Server terminated with error (1). Closing log file.

If I enforce the intel driver via a configuration file in /usr/share/X11/xorg.conf.d then Xorg reports a segmentation fault instead, but the overall effect is the same - no screen!

I have tried various fixes, but none have worked (I'm happy to try these again in case I got something wrong though!):

  • Adding i915 and intel_agp to the initramfs (suggested by the Arch Wiki)
  • Various configuration options in /usr/share/X11/xorg.conf.d
  • Updated drivers from ppa:oibaf/graphics-drivers and ppa:kisak/kisak-mesa
  • Installing a newer kernel (5.11)

I would be very grateful for any help that anyone could offer.

Thanks!

2
  • 1
    Hi and welcome. Since you tried 5.11 do I assume you were running 5.8? If so try 5.4 – David Mar 21 at 15:43
  • Thanks @David! I just tried the 5.4.0 and 5.4.107 mainline kernels, neither worked. – ColinC Mar 21 at 16:05
2

I solved this problem by installing a recent oem kernel (linux-image-5.10.0-1019-oem) which contains a fix for this issue, as suggested in the answer to this question: Blank (no signal) display on new ASUS Z590 motherboard

1
  • I am so thankful for your thorough documentation. I faced the exact same problem and went through the exact same steps as you with an Intel Core i3-10100 and an ASRock H510m itx a/c . Updating the Bios to 1.6 didn't help, but your suggested OEM Kernel works just fine! Thanks! – Haini Apr 18 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.