I'm struggling to downgrade my current CUDA version. I am using Ubuntu 20.04 LTS with NVIDIA GeForce RTX 3070 GPU, 460 drivers and CUDA 11.2. I am using tensorflow 1.13.1 as part of a machine-learning software package and for some reason the software doesn't work properly. I suspect this is because of CUDA, as I use the same software with NVIDIA TITAN V GPU, 450 drivers and CUDA 11.0 and the software works fine.

I've first tried downgrading the NVIDIA drivers to 450 as that automatically installs CUDA 11.0. However, it seems the RTX 3070 GPU only supports the 460 drivers, so downgrading the drivers is not an option.

Next, I tried downgrading only CUDA, without touching the drivers. First, I tried removing the current CUDA installation:

sudo apt-get --purge remove "*cublas*" "cuda*"

followed by installing CUDA 11.0 from the NVIDIA archive with the .deb (local) file (following the installation instructions on the website):

wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/cuda-ubuntu2004.pin
sudo mv cuda-ubuntu2004.pin /etc/apt/preferences.d/cuda-repository-pin-600
wget https://developer.download.nvidia.com/compute/cuda/11.0.3/local_installers/cuda-repo-ubuntu2004-11-0-local_11.0.3-450.51.06-1_amd64.deb
sudo dpkg -i cuda-repo-ubuntu2004-11-0-local_11.0.3-450.51.06-1_amd64.deb
sudo apt-key add /var/cuda-repo-ubuntu2004-11-0-local/7fa2af80.pub
sudo apt-get update
sudo apt-get -y install cuda

However, this always seems to automatically revert the drivers to 450, which leads to dependency conflicts. Based on this website, CUDA 11 should support >=450 drivers, so is it possible to downgrade CUDA 11.2 to 11.0 without changing the drivers?

Many thanks!

  • The .run file from Nvidia lets you skip the Nvidia driver installation. There are answers here for that, and for just unpacking the Nvidia deb without installing anything or having any dependence upon the Nvidia drivers, allowing multiple simultaneous cuda setups with different versions.
    – ubfan1
    Mar 20, 2021 at 20:13
  • Same problem here. If you try to downgrade cuda version from 11.2 to 11.0, the driver 450 crashes. You found any solution? Only solution that I found is to downgrade ubuntu from 20.04 to 18.04 to work with Tensorflow
    – Felipe
    Apr 9, 2021 at 19:08


You must log in to answer this question.

Browse other questions tagged .