0

I installed Ubuntu 20.04 on my ASUS ROG Zephyrus G15. I am not able to use the following keyboard action keys shortcuts(Fn+Function keys):

  1. Screen brightness(Up:Fn+F7 / Down:Fn+F8)
  2. Keyboard backlight(Fn+Up Arrow Key)
  3. Microphone mute(Dedicated button)
  4. Sleep(Fn+F11)
  5. Aeroplane mode(Fn+F12)
  6. Touchpad deactivate/activate button(Fn+F10)

Edit: I already tried adding acpi_osi= and later acpi_osi=linux after quiet splash in /boot/grub/grub.cfg, but no luck, the laptop would just hang with a blank screen after showing the boot logo.

If the solution is not available, how do I code it myself to make it work, please give me some pointers. Thank you.

2
  • find out how to issue those commands in a terminal and then make a Ubuntu shortcut key to make them work . it might require a script for instance to increment screen brightness and not go over the max value eg sudo tee /sys/class/backlight/amdgpu_bl0/brightness .... cd /sys/class/backlight/amdgpu_bl0$ cat brightness ;cat max_brightness ; cat actual_brightness – pierrely Mar 20 at 5:20
  • I went to this directory /sys/class/backlight/amdgpu_bl0/brightness. and found that the files you mentioned were there. But when I did $ sudo 52 >> actual_brightness and $ sudo 52 >> brightness, the brightness didn't change, and also permission denied message showed up. Any pointers, or can you tell what i am doing wrong? – Aswath Mar 20 at 7:46
2

I figured it out, I came across this asus-linux.org website and that had the solution. I just had to update my kernel to the latest version(5.11 as of now). I installed the latest kernel with Mainline kernel updater software.

The screen brightness and the keyboard backlight Function keys are working now. And some other bugs were solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.