4

I have a Dell XPS 13 2-in-1 running under Ubuntu 20.04 The pen (PN579X) was working well but suddenly stopped. Could anyone advise on how I could fix the problem?

2
  • 1
    I confirm the problem of the original poster. I have a Dell Latitude 2-in-1 running Ubuntu 20.10. A few months ago I bought a Dell Active Pen PN579X, which worked out of the box. However, almost on the same day as the original poster my pen stopped working as well. If I reboot my computer into Windows 10, the pen still works perfectly fine, so it's not a hardware problem. It may have to do with a recent update of Ubuntu 20.10. – Sjouke Mar 23 at 17:04
  • Try to use an older version of the Kernel. I did it today and the pen is working again. (Beginners luck...) – Ana Viana Mar 24 at 20:24
0

Hard to tell what has happened as it suddenly stopped working. Posting error logs, hardware configuration and such is always a good idea in order to get help. In any case, most do not get the PN579X working out of the box on 20.04. Upgrading to 20.10 seems to do the trick for some, see also this post.

4
  • Thank you so much for your reply. I must confess that though I use Ubuntu I am not good with it (but it's so much better than Windows!). I have upgraded to 20.10 but had no luck. I would need help to post whatever info might be relevant. Would it be easy for you to guide me on that? – Ana Viana Mar 22 at 20:29
  • I've been using Ubuntu for years and think it's just great. There's no going back to WIndows, even if there may be an occasional problem with the hardware. As for the problem at hand; will try a couple of things and post it here asap. Please also note the other post referred to above. – ElToro1966 Mar 24 at 9:53
  • Thank you very much for the support! No, there is no way back to windows, though when I face these problems I spend several days trying to fix the problem. Today I went back to an older version of the Kernel and the pen is working again. (Beginners luck...) – Ana Viana Mar 24 at 20:25
  • That's great! 5.8.0-44-generic seems to work as per askubuntu.com/questions/1295045/dell-xps-13-9310-2-in-1-drivers. I made the mistake of upgrading the firmware for the pen, and now it won't even connect via Bluetooth... – ElToro1966 Mar 26 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.