0

I upgraded a bunch of old machines from Xubuntu 18.04 to 20.04, everything going smooth except a distressing flickering when windows go on focus or scroll (i can briefly see other windows that are in the background) I think it's a graphic driver issue but i'm unable to switch from nouveau drivers to proprietary nvidia ones, because Software & Updates -> Additional Drivers shows no output. Even the command

ubuntu-drivers devices

gives no output Is there anybody experimenting the same problems or able to help me? Thanks, Lorenzo

lspci | grep VGA gives: VGA 00:12.0 VGA compatible controller: NVIDIA Corporation C68 [GeForce 7025 / nForce 630a] (rev a2)

7
  • Since there is no version 18 or 20 do I assume you mean 18.04 and 20.04? – David Mar 18 at 11:17
  • Did you try sudo ubuntu-drivers autoinstall? – singrium Mar 18 at 11:22
  • What Nvidia hardware do you have? In a terminal (ctrl-alt t to start one), run the command lspci and add the VGA line(s) to your original posting. Very old hardware may need an old driver not normally provided in current releases. – ubfan1 Mar 18 at 22:05
  • @David yes, sorry... i didn't know details of version numbering, it's from 18.04 to 20.04 and - by the way - it's not a true upgrade but a complete re-installing from scratch on the same hardware. I can still boot old 18.04 on a separate partition if it's useful for confrontations. – Lorenzo Ceriani Mar 19 at 8:16
  • @singrium: sudo ubuntu-drivers autoinstall gives "No drivers found for installation" – Lorenzo Ceriani Mar 19 at 8:16
0

You need to black list your nouveau driver when your linux boots up cause of some dependency problems nouveau drivers are not best suited for some graphics card. After successfully booting up you had to switch from opensource driver that was that nouveau driver to proprietary driver by nvidia .

Please follow this link for how to blacklist that driver What does modprobe.blacklist=nouveau do?

2
  • I tried that. I get a 640x400 screen from which i can still work, but still i'm not able to install any other useful driver repeating the operations described in the post. – Lorenzo Ceriani Mar 19 at 7:59
  • So that 640x400 screen is shown after you boot up black listing that nouveau driver. If that's true then you had to manually install driver from nvidia's website. – HARIS UMAID Mar 20 at 7:40
-1

Have you tried updating the whole pc after updating Ubuntu version using: sudo apt update && sudo apt upgrade

1
  • Yeah, great! It was too simple to be true but it's ok now. I still don't understand what could be the problem, but now it's ok. Thanks a lot – Lorenzo Ceriani Mar 19 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.