I have a Dell Studio XPS 1647 and headphones do not work (though , internal speakers work like a charm) , I have dual boot Windows 7 and headphones work perfectly fine ...

I also tried -adding in options snd-hda-intel model=eapd probe_mask=1 position_fix=1.

I've experienced this with Oneric Ocelot and the latest Precise Pangolin (LTS).

  • 1
    // , Please add output for the following command: $ lspci | grep Audio. This will show your audio chipset, among other things, e.g. 00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04) – Nathan Basanese Sep 13 '16 at 5:42

13 Answers 13


I've tried all these responses. Here is the ONLY way that worked for me (and it was remarkably quick... after spending hours on all the other suggestions!). Go into Terminal, and simply key this in:

$ alsactl restore

And that's that! :)

  • 8
    Ok. I had to do a full shutdown and not a restart. Only then did it work for me. I'm using an ASUS K56--30 – mwangi Dec 6 '16 at 9:24
  • 16
    This worked on my XPS 13 9360 (Ubuntu 16.04.2). Headphones started working immediately after that. My unit looses the headphone irregularly. – sola Mar 22 '17 at 0:28
  • 2
    This worked perfectly. – Jin Dec 5 '17 at 15:29
  • 4
    Work for me on acer swift 3. Funny that I did not need to restart or anything, sound was instantly turn on as soon as I hit enter. – Tg. Apr 20 '18 at 1:45
  • 6
    This didn't work for me on Ubuntu 18.04 with an hp spectre 360. I got an error when running the command: alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists – Marses Sep 7 '18 at 21:24

I had the same problem. Following these instructions got my headphones working.

Open the terminal and enter the following commands:

cd /usr/share/pulseaudio/alsa-mixer/paths/
sudo cp analog-output-headphones.conf analog-output-headphones.bak
sudo nano analog-output-headphones.conf

Look for the section called [Element Speaker] and change it so that it looks like this:

[Element Speaker]
switch = on
volume = ignore

Save the changes and exit nano.

Create a backup of the corrected analog-output-headphones.conf:

sudo cp analog-output-headphones.conf analog-output-headphones.fixed

Now you can restore the fix if a future installation or update overwrites it.


After rebooting, you may need to remove and reinsert the headphone plug to get it to work. After it's working, though, you will be able to remove and insert the plug, and behavior will be as expected.

  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Oyibo Nov 19 '12 at 13:13
  • 1
    ...like a charm. – nietaki Jan 14 '13 at 10:56
  • 3
    On LUbuntu 12.04 this doesn't work for me. Also you can reload the sound system, by first killing pulseaudio pulseaudio -k and restarting alsa: sudo alsa force-reload. No reboot needed. – Calmarius Oct 5 '13 at 13:22
  • 15
    This did not work on a 2013 Dell XPS 13 running Ubuntu 16.04. – Mark Stosberg May 19 '16 at 14:31
  • 1
    @OmidHezaveh No. I still use alsamixer to manager my volumes now instead of the usual system volume management. – Mark Stosberg Dec 5 '16 at 15:29

Finally got Headphones to work ! Follow this ----- (Dell)

This is it :

Run the following command into the Terminal:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Scroll down and add these lines to the end of the file:

# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m6-amic

Then, save , reboot and test sound using headphones and speakers.

  • 11
    This is always the comment that I end up finding that fixes my sound after I reinstall my laptop. So thanks, and hi future me :-) – tsimon Aug 8 '14 at 22:34
  • 3
    I didn't have to reboot. Instead run sudo alsa force-reload and then unplug and insert the headphone. – buzypi Oct 26 '14 at 7:34
  • 2
    didn't work my dell xps 13, 9360 running ubuntu 16.04 sound comes from both speakers and headphones – Nick Dec 4 '16 at 18:31
  • Worked like a charm on my ThinkPad P50 with Ubuntu 16.10 – rafaelcpalmeida Mar 7 '17 at 14:29
  • In my case, this only detects the headset when it is plugged while rebooting. Before the last update, ubuntu detected the plugin action and asked you whether this where headphones, mic or headset. How can I get that behaviour?. – Daniel Cerecedo Mar 21 '17 at 11:27

i had same issue after installing 16.06 ubuntu gnome in my dell xps. then i solve this issue by .......

sudo apt-get install pavucontrol

after install pavucontrol. open it by simply typing terminal pavucontrol.

then go to -> Output Devices tab -> change port

in my case seleted port was Headphones(plugged in) by default after plug headphone

enter image description here

change port Headphones(plugged in) to speakers (unavailable).

enter image description here

this is a temporary fix.after rebooting your pc you have to do this again.

  • Great tool, exposed everything that I needed to find out what was going on, without any ugly config hacks. – Kzqai Sep 19 '16 at 17:09
  • the best and only working for me solution! and the most elegant – izy Jul 15 '20 at 8:43
  • headphones not showing up in KDE with this tool or in KMIX. – sjatkins Jul 27 '20 at 21:34

The solution in a comment above by buzypy worked for me, without any of the other stuff:

sudo alsa force-reload

then reopen pavucontrol and change to the option Headphones (unplugged) and restart the program that was playing the sound.

It's problems like this that make people not want to use Ubuntu!

  • 1
    Yeeee-haw. After mod probing and alsa installing and muting and unmuting etc etc etc... <3 – Lotus Aug 19 '17 at 22:20
  • 1
    All I had to do was run "sudo also force-reload" and it started working right away. (Ubuntu 19.10) – denshigomi Jan 4 '20 at 18:04
  • 1
    Doesn't work for me. 20.04 – mathtick May 12 '20 at 13:46
  • But why is it not detecting I have plugged in my headphones? – Daniel Cheung Aug 29 '20 at 6:08

I had to do the following:

  1. Exit out of google chrome (I'm trying to get music to play in a tab)
  2. in a terminal, run killall chrome -- will probably say "none found" or whatever
  3. kill pulseaudio with pulseaudio -k at a terminal. (it should restart silently in the background, but if not, try pulseaudio -d)
  4. now run sudo alsa force-reload (Thanks @mjp!!)

I had the same issue. I did as below

  • Go to Settings
  • Click on Sound settings under hardware section
  • Click output tab (automatically selected by system)
  • On the bottom side: set the output volume to 100%

Thanks to https://superuser.com/questions/357623/headset-is-not-working-with-ubuntu-11-10

  • i already have tried that . not working – lexical lemon May 18 '12 at 6:24
  • 3
    Not a solution because only headphones jack isn't working. – Pavel Vlasov Aug 11 '12 at 12:15
  • Helped for me. My headphones were muted for some reason. – Serge Vinogradoff Jun 14 '14 at 21:27
  • For Ubuntu 18.04 Under Output Tab Selecting 'Line Out Built-in Audio' helped restore sound. – SMJ Sep 10 '19 at 5:51

On my laptop, a Lenovo G465, the sound was working well: each time I plugged the headphones, it would be detected and sound was piped through the headphones and muting the speakers. Suddenly it stopped working. Something weird happened without any changes or installation or whatsoever. I read that someone had to use alsamixer to activate it: lo and behold: I tinkered with the volumes and mutings and suddenly it started working again as before!!! I have no explanation, honestly.

  • Experiencing the same thing with my Lenovo laptop this morning :) Playing with sound settings though nothing seem to help - I hope it starts working again like in your case :) – Yuriy Nakonechnyy Feb 14 '13 at 8:15
  • Rebooting helped :) – Yuriy Nakonechnyy Feb 14 '13 at 8:30

In my case, for a Dell E5450, it was resolved after runnning:

sudo modprobe snd-hda-codec-idt

To day I got it in easy way:

How to using headphone in Ubuntu:

  1. Install update for Ubuntu.
  2. Install GNOME alsa mixer.
  3. Plug in both of back speakers and front headphone.
  4. In ALSA: mute your front column, unmute in Headphone.
  5. Go to Sound setting: unmute your sound that was made by ALSA.
  6. Click the Test Sound button to go to Test Sound in Sound settings, check left and right ==> ONLY HEADPHONE has sound, Speaker will be silent.

enter image description here

enter image description here

enter image description here



I just recently upgraded to Ubuntu 20.04(KDE) and faced the same issue. None of the answers gave a permanent fix. The closest fix was by Pepe Lebuntu.

alsactl restore

However I had to do this everytime I replugged my headphones which became annoying. So I made an acpi event which triggers this command when headphones are plugged.

To do so create a file in the directory /etc/acpi/events

cd /etc/acpi/events
sudo nano headphone-fix

And add the following lines in the file

event=jack/headphone HEADPHONE plug
action=alsactl restore

Save and exit then restart the acpi service using

sudo service acpid restart

Replug your headphones and it should now be working everytime you plug it back


None of the previous answers posted fixed my issue on Ubuntu 18.04 LTS nor on 16.04 LTS. My computer uses a Clevo motherboard and luckily a developer known as Unrud created an easy fix called "init-headphone", which for the Ubuntu distro it is called "init-headphone-ubuntu". Basically, you just install the ".deb" package for Ubuntu and that's it, with no restart required (at least this was true for me).

To be clear, at this time, Unrud did not specifically create an 18.04 package, so I used Unrud's 16.04 (Xenial) package on 18.04 and it worked like a charm!

  • 5
    Please don't add signatures under your posts. See meta – Zoe Jun 17 '18 at 18:20
  • I have a Clevo P67SE motherboard, I installed your same package and even rebooted but unfortunately headphones still aren't detected while using the jack – Stefano Aug 4 '18 at 18:10

During boot, I was passing the parameter acpi=off (see Booting Ubuntu with "acpi=off" grub parameter).

After removing acpi=off, the headphones worked again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.