0

Ubuntu server 16.04 PHP7.4 Apache2 running wordpress Geotrust SHA256 certificate

I have started getting the following error

cURL error 60: SSL certificate problem: unable to get local issuer certificate

I have read through and tried most solutions on the many questions on here, but to no avail

The latest 2 i have tried is adding to php.ini the following 2 lines and restarted Apache and rebooted after each one to see if it solves the issue. But it does not

After downloading a fresh copy of cacert.pem The first one i tried was

curl.cainfo = "/path/to/cacert.pem"

Then i tried

openssl.cafile = "/path/to/cacert.pem"

But i still get the same error

Any assistance greatly appreciated. Many thanks

1

1 Answer 1

0

I eventually placed this config in the Apache host file for the 443 connection.

SSLProtocol all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
SSLCertificateFile /etc/ssl/certs/your_cert_name.pem
SSLCertificateKeyFile /etc/ssl/private/www.your_key_name.co.uk.key
SSLCertificateChainFile /etc/ssl/certs/your_intermediate.crt

Hope that helps

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.