2

I am currently running Ubuntu 20.04 with 5.11 kernel on a dell xps 15 9500 with i3 wm. Since yesterday I'm having a problem about the laptop monitor: it is no longer seen as eDP-1 but eDP-1-1. This implies that brightness keys are no longer working and that when I escape from i3 (with mod+shift+Esc) the PC get stuck on the purple login screen, without any user selection box or whatever. I am quite sure that the monitor name problem came after a mod I tried to apply yesterday, before everything happened: I was trying to make the brightness control working and I found a guide that creates a .sh file that changes the value in /sys/class/backlight/intel_backlight/brightness once I use the keys; unfortunately this procedure didn't work, so I tried another solution, the use of "light" app. It worked perfectly, till today, after the first startup: the stuck problem and key not working. Do you have any solutions? Where I can modify back the monitor name?

xrandr --listmonitors 
Monitors: 1
 0: +eDP-1-1 1920/336x1200/210+0+0  eDP-1-1

Thank you in advance for your help!

P.S. I will not be able to run a full reset, it's my working laptop!

0

You must log in to answer this question.

Browse other questions tagged .