I have recently dual booted Ubuntu 20.04 L.T.S on my windows laptop. And while sharing my screen through teams or google meet, I am unable to share my computer audio, nor there are any options to toggle them. I have heard that by using the Pulse Audio and Jack Audio, I can share my audio too. Can anybody tell me what they are how to set them up. Should I just leave it and not mess with any of my settings ?

1 Answer 1


Before you begin, go to the Google meet or the teams website using Google Chrome and click on the padlock next to the URL. Then, click on site settings and set the Microphone to "Allow".

PulseAudio is your default audio manager so you can change the settings through your system settings in the audio or sound settings section. Your problem can be solved using Jack but I don't think it's necessary.

First, open your Sound Settings or navigate to Sound under your System Settings.

The "input" and "applications" sections are relevant here and you might need to edit these sections while teams or google meet is running.

Sometimes the devices and/or applications are set to mute by default. You can also select input devices and adjust the volume.

If you are not able to get the microphone working through the default settings section, you can install the PulseAudio Volume Control application.

First, install the application by running the following commands:

sudo apt update
sudo apt install pavucontrol

Next, search for "pulseaudio volume" or "pavucontrol" in your installed applications.

Here, the relevant sections are "Recording", "Input Devices", and "Configuration".

The Recording section will only show applications that are currently in use to it's best to check this section when teams or google meet is running.

Under the Configuration tab, you can set your audio adapters to "Duplex", which is both input and output, or you can set to "Input" or "Output" and there may be a few other stereo, digital, analog, and mono options and combinations available.

Under the Input Devices section, you can select different devices for different adapters.

Of course, you can adjust the volume in all of these sections as well.

Your third option is to install alsa-utils. PuseAudio acts as a middleman between you and ALSA. However, you can adjust ALSA settings directly.

Install the alsa-utils package:

sudo apt update
sudo apt install alsa-utils

and then you can run the following command to use the alsamixer:


First, use the left or right arrow key to navigate to "Auto-Mute Mode" and then use the up or down arrow key to Disable this option.

Next, press F5 to show all items. Now, you should see options for internal microphone, mic-boost, and others.

Use the up or down arrow keys to adjust the volume and press the M key to mute or unmute an item.

Also if you have more than one audio adapter or sound card, you can press F6 to adjust the settings for a different card.

  • Thank you, @mchid for explaining it very clearly. It really gave me a good view on what is what. But the thing is the audio through my microphone is getting shared, but say when share screen and play a youtube vide, there is no option like in windows saying include system audio, which is resulting in the sharing of the video with out the audio. Mar 15, 2021 at 10:30
  • @RakeshGoud Okay, this is called the "loopback" and/or "monitor" for the input device. I will add some additional instructions.
    – mchid
    Mar 15, 2021 at 10:39
  • Thank You. @mchid Mar 15, 2021 at 10:55
  • @RakeshGoud I just tested out on my system. If I want both microphone and system to record, I have to set Duplex under the Configuration tab, make sure the volume is up for both the Monitor and the Microphone Under the Input Devices tab. Then, under the Recording tab it records both the microphone and the system when this is set to "Built in Audio". It will only record the system if it is set to Monitor under the Recording tab. Sometimes it takes trying out each of the settings to see which one works.
    – mchid
    Mar 15, 2021 at 11:07
  • I have checked all of that in the pulse audio volume control and everything is set same. But the audio of the shared video is not audible yet to the other person I am sharing with. Should I install qjack ? Mar 15, 2021 at 11:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .