0

I have a Ubuntu guest on a Win10 host. I shared a host directory using VMWare's Shared Folder feature (/mnt/hgfs/HostData) and that works great. What I'd like to do is change the owner and set permissions on that folder.

I added the following line to /etc/fstab:

.host:/ /mnt/hgfs/ fuse.vmhgfs-fuse uid=33,gid=33,umask=007 0 0

However, when I boot up the shared folder has the default permissions (drwxrwxrwx root root). I can get the desired permissions by unmounting and running the fstab file:

umount /mnt/hgfs/
mount -a

My assumption is that VMWare is mounting the folder elsewhere and it is taking priority, but I don't know where to make changes (or if my assumption is incorrect). I'm completely new to Linux, so feel free to assume I've made a very basic mistake.

Update

I attempted to mount to a new directory (rather than the one VMWare uses):

.host:/HostData /mnt/hostdata fuse.vmhgfs-fuse uid=33,gid=33,umask=0007 0 0

This results in a weird state when first booted: The permissions are listed as d?????????. umount then mount -a gets the desired results. This leads me to believe that the fstab file is executed before VMware has the shared folder ready.

3
  • Does this helps you? – Nicolas Formichella Mar 15 at 9:59
  • That might suffice, I'll give it a shot @NicolasFormichella – MikeH Mar 15 at 19:22
  • See update @NicolasFormichella – MikeH Mar 15 at 19:57
0

I've given up on my original goal of modifying the permissions of the mount point that VMWare creates. Instead (as suggested by @NicholasFomichella) I'm creating a new mount point which seems to give me the desired results. The following line what I ended up with in /etc/fstab:

.host:/HostData /mnt/hostdata fuse.vmhgfs-fuse allow_other,uid=33,gid=33,umask=0007 0 0

Note that is fails without allow_other as an option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.