I have been trying to install (i.e. dual boot) Ubuntu 20.04 LTS on Macbook Pro 2019. I disabled the T2 chip and disabled the security system by > csrutil disable in recovery mode. I followed the usual steps:

  1. created a boot-able image on a USB flash device (using Etcher). The iso image was obtained from ubuntu.com.

  2. disabled T2 and SIP security system in recovery mode as stated above.

  3. Created 100 GB GUID formatted FAT32 partitions on internal SSD

  4. Held "Option" key as power on the computer

  5. EFI rebooted from USB drive

  6. Clicked on "install Ubuntu", chose "allow third party ...", then "something else".

  7. On the table for manual partitioning, chose the partition on which Ubuntu was supposed to be installed, "Ext4journaling file system", "format the partition", mount point "/". Clicked on "continue".

  8. Got the message:

    the attempt to mount a file system with type vfat in/dev/nvme0n1p1 at /boot/efi failed

  9. Clicked on continue. Then a screen with message

    Creating ext4 filesystem for / in partition #3 of /dev/nvme0n1...

  10. The installation got stuck in this stage for hours until I turned off the computer.

I even tried running Ubuntu from live USB drive, using GParted tool to partition the drives. The results was the same.

I also tried installing Ubuntu on an external sda drive with its own EFI partition. The result was the same. I still got the message "the attempt to mount a file system with type vfat in/dev/nvme0n1p1 at /boot/efi failed" and froze on "Creating ext4 filesystem for / in partition #3 of /dev/nvme0n1..." the same as above.

BTW, I also tried installing rEFI boot manager with no success. I have basically followed the instructions in https://linuxnewbieguide.org/how-to-install-linux-on-a-macintosh-computer/#refind and some other places without much success.

I tried dual booting with two different MAC OS, Catalina and Big Sur. The results were the same. Reinstalled Mac OS a couple of times to ensure, file corruption is not causing this. Always obtained the same results.

1 Answer 1


Mac is a bit difficult when it comes to dual booting, so you'll have to use Disk Utility to create separate partitions for /boot and /boot/efi such as:

ubuntuStorage = / ext4 (arbitrary size)
SWAP = swap 8gb
bootEFI = /boot/efi EFI System Partition 1024mb
boot = /boot ext4 1024mb

Make sure all of these partitions are formatted at FAT/FAT32 as you've previously mentioned, and format them in the Advanced Installer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .