0

So i tried to install realtek drivers on my pc. 'Rt linux HDaudio 5.18'. Then i followed the steps in the manual:

Installation: This Source Code is from www.alsa-project.org. For OS installation, please remember add the Development tool kit. For driver installation, please follow below steps.

Note: Please check Development tool kit on your OS.

Manual install: Step 1. unzip source code tar xfvj alsa-driver-1.0.xx.tar.bz2

Step 2. Complied source code a. cd alsa-driver-1.0.xx b. ./configure --with-cards=hda-intel c. make d. make install

Step 3. reboot your machine

Step 4. Use the alsamixer the disable mute (All audio line default is mute) excute alsamixer

Note: 1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt in the azx-021705.tar.bz2. 2. Kernel Version must be 2.6 or later. 3. All mixer channels are muted by default. You must use a native or OSS mixer program to unmute appropriate channels. 4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux. 5. The driver added to support the SPDIF functoin.
6. a. You can download the alsa-lib-1.0.x and alsa-utils-1.0.x form the www.alsa-project.org, then unzip and install them. b. Suggest use "alsamixer" to control mixer function. c. Used "alsaconf" can autodetect which drive you need to install (step 4).
7. SUSE Distribution must install the ncurses package.

After that it gave me some error so i tried installing it again but the same error appeared. So i gave up on this and continued my work. On the next day (today) i turned on my computer and noticed that i have no audio. In the sound settings on 'output device' i have 'dummy output'. So i tried to fix it by reinstalling 'alsa' and 'pulseaudio' drivers, that didn't helped. I installed 'inxi' package and ran it with -SMA parameters. That's what i got: image link?

kysaba@apollo:~$ sudo alsa force-reload
[sudo] password for kysaba: 
Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).
kysaba@apollo:~$ inxi -SMA
System:
  Host: apollo Kernel: 5.8.0-44-generic x86_64 bits: 64 
  Desktop: Gnome 3.36.4 Distro: Ubuntu 20.04.2 LTS (Focal Fossa) 
Machine:
  Type: Desktop Mobo: ASUSTeK model: MAXIMUS VIII RANGER v: Rev 1.xx 
  serial: <superuser/root required> UEFI [Legacy]: American Megatrends 
  v: 2202 date: 09/19/2016 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio driver: N/A 
  Device-2: NVIDIA GP107GL High Definition Audio driver: N/A

So i guess the problem is with these N/A driver things. I tried to google it but only got the solution that i already tried, like reinstalling alsa and pulseaudio.

And help hands with this?

1

1 Answer 1

0

Follow Only "Dummy output" (sound) in Ubuntu 20.04 after reboot - Broken driver / module and post outputs.

In addition to the recommended set of initial diagnostic series of commands, I guess in the end the most likely commands that would help you are:

$ modprobe --show-depends snd_hda_intel
$ sudo apt-get install linux-modules-extra-<your kernel version>-generic

and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.