1

I'm kind of new so please go easy on me.

I just installed ubuntu as dual boot alongside windows 10 (Ubuntu 20.10 is my current version) and I'm trying to install vim.

I've tried sudo apt-get update and then sudo apt-get install vim, but that returns:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package vim is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'vim' has no installation candidate

When I try to use vim it returns:

Command 'vim' not found, but can be installed with:
sudo apt install vim       # version 2:8.2.0716-3ubuntu2, or
sudo apt install vim-tiny  # version 2:8.2.0716-3ubuntu2

So I tried installing vim-tiny, which returned:

Building dependency tree       
Reading state information... Done
vim-common is already the newest version (2:8.2.0716-3ubuntu2).
vim-common set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

However the situation hasn't changed in the slightest.

Trying to install vim-gnome or any other vim package resulted in an error like the one when I tried installing vim

I've tried to sudo apt-get update and then sudo apt-get upgrade and try everything all over again but nothing has changed.

Any help would be greatly appreciated (both regarding the problem and whether my question format should be changed)

2

1 Answer 1

0

vim is a package that is available in the standard Ubuntu Software sources, in the "main" repository. That you cannot install it indicates that there is a problem with your configuration or with the server you are connected to.

  • First check your software sources in "Software & Updates", tab "Ubuntu Software". All sources, except eventually "Source code", should be enabled.
  • If the source is properly enabled, try selecting a different server next to "Download from" on the same tab.
3
  • Thanks a lot, it works now. I'm sorry I answered so late to your quick reply. Thank you very much.
    – Some Guy
    Mar 13, 2021 at 20:49
  • Glad this was of help. Just out of curiosity, what was the issue? The source settings or your server?
    – vanadium
    Mar 14, 2021 at 10:57
  • it was the server. I switched to USA
    – Some Guy
    Mar 14, 2021 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.