28

I can't find where this shortcut is defined. How can I disable it?

2

3 Answers 3

33

This is what worked for me

  • Open a terminal and run dconf-editor
  • Navigate to org > gnome > desktop > wm > keybindings
  • Find ['<Super>Above_Tab', '<Alt>Above_Tab']
  • Set it to ['disabled']
  • This should free up that binding for you to use elsewhere.

(ps: I use alt-grave to switch back one application like you can in mac - works well for me and the setting for that is in dconf-editor under the same place


For those of you that don't know what a grave is, it is the key right above the tab key and to the left of the number 1 key it looks like this (`). It's also known as a backtick and is used in mark down and python as a comment like this

`code here`
```or in some markdown dialects, code here``` 
6
  • 1
    What is the actual rule called in here>? As I can't find it linked to the commands you are saying Feb 13, 2017 at 11:18
  • Anyone managed to sort it out on Ubuntu 16.04? Worked fine for me on 14.04 and also migrated to 16.04 on upgrade, however stopped working on a fresh install
    – SyBer
    Feb 14, 2017 at 18:36
  • Did a cross-question at superuser.com/questions/1178633/…, if someone wants to earn points.
    – SyBer
    Feb 14, 2017 at 18:37
  • 1
    Wish I could upvote my own post.... I use this every time I install Linux Aug 11, 2017 at 7:16
  • 1
    see this answer for ubuntu 18.04
    – adl
    Jun 19, 2019 at 7:26
30
  • Install the compizconfig-settings-manager Install compizconfig-settings-manager package
  • The setting can be found in Desktop, Ubuntu Unity Plugin, Switcher
  • Change Key to flip through windows in the switcher from disabled to something else.

And the reason you can not find it: disabled means it uses alt+` so it is impossible to find if you did not already know where it is used for ;)

5
  • This isn't working for me with Ubuntu 12.04. I gave it another key. I've ticked the "Enable Ubuntu Unity Plugin". I've rebooted. But it doesn't respond to the new key and Alt+~ still functions.
    – Tergiver
    Dec 27, 2013 at 19:52
  • 1
    This does work for me in 14.04 to stop the default window switcher from using alt-grave. But in order to then use alt-grave for something else (the static window switcher) I also had to use @codenamejames' answer below. Thanks! Nov 18, 2015 at 20:25
  • (in fact, after using both this answer AND @codenamejames answer, I still couldn't get alt-grave to work as static-switcher prev window. It was still bound to some 'unity switcher prev window on this workspace' action. So I did this answer over again, for every action on the unity plugin switcher's tab's list of keybinds. That seems to have nuked it.) Nov 18, 2015 at 21:29
  • Run compizconfig-settings-manager with ccsm.
    – davidA
    Dec 13, 2016 at 5:04
  • Caution: in my settings, this wasn't disabled, but rather, was assigned to a key that was already bound to something else. Mar 14, 2018 at 3:32
3

Or as a one-liner:

gsettings set org.gnome.desktop.wm.keybindings switch-group "[]"
1
  • 1
    Thanks! For those wondering, this is basically the same answer as the one from @codenamejames but quicker :) Sep 29, 2021 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.