2

I run multiple Ubuntu 20.04 servers on several Proxmox Hypervisors.

1 server has just encountered an issue with its apt updates but the other servers are all OK. Ubuntu server versions are all the same (20.04.2) and all are just running CLI.

All server /etc/apt/sources.list are identical The error I'm seeing on the 1 server is

Err:1 http://security.ubuntu.com/ubuntu focal-security InRelease
  400  Bad Request [IP: 91.189.91.39 80]
Err:2 http://ubuntu.mirror.serversaustralia.com.au/ubuntu focal InRelease
  400  Bad Request [IP: 27.50.85.5 80]

Reading package lists...
E: The repository 'http://security.ubuntu.com/ubuntu focal-security InRelease' is not signed.
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/focal-security/InRelease  400  Bad Request [IP: 91.189.91.39 80]
E: The repository 'http://ubuntu.mirror.serversaustralia.com.au/ubuntu focal InRelease' is not signed.
E: Failed to fetch http://ubuntu.mirror.serversaustralia.com.au/ubuntu/dists/focal/InRelease  400  Bad Request [IP: 27.50.85.5 80]

All other servers are updating fine, are all on the same subnet, same DNS, gateway etc. Below is the same "sudo apt update" command executed on one of the other servers

Hit:1 http://ubuntu.mirror.serversaustralia.com.au/ubuntu focal InRelease
Hit:2 http://security.ubuntu.com/ubuntu focal-security InRelease
Reading package lists...
Building dependency tree...
Reading state information...
All packages are up to date.

I attempted to install "inetutils-traceroute" but can't do that as the repos are broken. I can traceroute to security.ubuntu.com from any of the other servers no problems.

This is a production server and I could roll-back to a previous snapshot but confident the clever community out there can point me in the right direction. As this is a production server, I don't 'play' with its settings.

1 Answer 1

8

I had to seriously edit the /etc/apt/sources.list

converted all instances of

deb http://ubuntu.mirror.serversaustralia.com.au/ubuntu/ focal main
deb http://security.ubuntu.com/ubuntu/ focal-security main

to another repository and included trusted=yes on each line

deb [trusted=yes] https://mirror.internet.asn.au/pub/ubuntu/archive/ focal main
deb [trusted=yes] https://mirror.internet.asn.au/pub/ubuntu/archive/ focal-security main

apt updated and upgraded the server after that. YAY!

After applying the upgrades, I then edited sources.list again and removed all instances of "[trusted=yes]". Retested and all AOK

1
  • thanks, it's worked for me..
    – nur zazin
    Sep 13, 2023 at 14:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .