Ubuntu 20.04.1 Using Mate desktop. External USB drive WD 1TB /dev/sdc

Have spent at least four hours trying to give permissions to this external drive I'll be using for back up and have failed with every attempt.

Drive was formatted with Gparted using ext4. I can mount it in FILES and it shows a blank white screen. I can rgt click inside that and it gives me all sorts of options and I've tried them all trying to Paste any folder or files inside...and Paste is always grayed out.

I've tried sudo chmod -R a+rx (and uppercase X too) /dev/sdc and several other Term commands trying to get it to allow me to use it as a Bkup drive without success.

I've opened Permissions with a rgt click in that drive and no matter what command I've tried, in Root, or Term, afterwards in permissions it always shows me 'You are not the owner, so you cannot change these permissions."

Yes, I've tried several 'Change ownership' commands after searches but most of the instructions are from years ago.

Any ideas?

  • I'd just navigate to the drive, go up a level, and use 'chown' to take ownership of the entire drive all at once. Something like sudo chown kgiii:kgiii /drive/path (adjusted for your use case, of course).
    – KGIII
    Mar 11, 2021 at 2:28
  • 2
    Did you create partition(s) like sdc1 or just format drive like sdc. You need to have at least one partition and run command on that partition not the drive. You also need to mount the /dev/sdc1 to something like /mnt/data or /media/$USER/data and use that path for your chown command.
    – oldfred
    Mar 11, 2021 at 3:35
  • No, I did not create a partition. I'll go do that now.
    – Jim_HiTek
    Mar 11, 2021 at 3:36
  • Well, I guess it did it for me. Shows as sdc1.
    – Jim_HiTek
    Mar 11, 2021 at 3:45
  • I went up a level in Term and tried that command and don't see any difference. Still don't have permissions. I'm not suppose to reboot between attempts am I?
    – Jim_HiTek
    Mar 11, 2021 at 4:12

1 Answer 1


Solved Well, sort of. The solution for this particular HDD was to open Disks, and reformat the drive for Fat32. Now I can at least copy to the drive.

Thanks for the help. I wonder what the problem is?

I have found that Deja Dup won't work with this drive now. It insists that 'Storage location not available'. And it's 'Waiting for '1.0TB Volume' to become connected'. So I'm just doing straight copies of my Home dir.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.