0

first time poster here so I apologize if things are completely formatted etc.

I am running on a Windows 10 host machine using a Hyper-V virtualization environment. When setting up the VM I use the default 18.04.5 image (5.4.0-42-generic #46~18.04.1-Ubuntu per uname -a), when I pull updates (updating me to 5.4.0-66-generic #74~18.04.2-Ubuntu) and reboot the machine takes forever to do so (assuming due to waiting for X11/Xorg to fail) and I have to get in via the tty2 console.

I was also able to replicate this behavior using the quick setup option in hyper-v when making an ubuntu machine as well. Additionally, I have made an xorg.conf file and tried the modsetting and fbdev drivers. While the modsetting works on the machine pre-update but afterwards is not able to detect the graphics driver. The fbdev driver is able to detect the graphics driver but I run into a "fbdev(0) mmap fbmem invalid argument" issue.

Here is the Xorg.0.log : https://pastebin.com/hU03SYvn

Thanks in advance!

3
  • I've got no answer, but I have a similar problem on the hardware itself, with Ubuntu 20.04. My work around is after the boot cycle has failed, I use ctrl+alt+f2 then ctrl+alt+f1, effectively restarting gdm3. This could also be done at tty2 with sudo systemctl restart gdm3 - does this work on your system as well? Mar 11, 2021 at 2:58
  • Thanks for the response. Looks like gdm3 just re-crashes when I restart it with the same errors.
    – NeinNine
    Mar 11, 2021 at 19:21
  • K - Mine seems to be a lack of proper detection of the HW - it may be that there's a timeout for hardware startup which is not being respected, perhaps. I will later switch to 21.04 to see if there's improvement... Mar 11, 2021 at 20:26

1 Answer 1

0

I had the exact same problem. I was able to recover by rerunning the Windows Tools for Ubuntu setup for Enhanced session here: How to install Ubuntu 20.04 on Hyper-V with enhanced session. Follow steps under "Setup Enhanced Session" until the end. This assumes that you have Console or CLI access to the Ubuntu guest OS (CTRL-ALT-F2 to open a new console).

1
  • Thanks for the response. I am needing the VM for work so I can validate a large number of software packages provided by third-party vendors so updating each and every package is not feasible given the time I have. Unfortunately, the vendors are no longer under contract and the deliverables were not touched for a few years before I was assigned them. I did also notice that this was also an issue with Ubuntu 16, so I suspect a Windows stealth update broke things. I suppose I will need to get some new hardware to stick Ubuntu on so I can get this taken care of.
    – NeinNine
    Mar 13, 2021 at 22:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .