Notifications are no longer working in Gnome 3.4 but they are working in Unity. I have tried everything I can think of but I am stumped.

To clarify, I am changing the theme using Gnome Tweak. Themes were obtained from various repositories including noobslab/themes and webupd8. As an example, when using the default theme adwaita, I get all notifications when using Rhythmbox as to what song is being played on an internet radio station. I even tried a different media player with the same result. When I change the theme, all I get is a media player Icon. Change back to default theme and all Notifications work fine. Notifications were working at first with all themes, but no longer. The question is how to get Notifications to work for all themes. They did for previous versions of Gnome-shell.

  • Have you definitively used a gnome3.4 compatible theme? I presume you are aware that gnome3.2 themes will give you display issues when used on gnome 3.4? – fossfreedom May 8 '12 at 15:47
  • Yes, all themes currently installed are 3.4 compatible. – chazdg May 9 '12 at 14:22
  • ok - it would be very useful if you can provide the exact links and themes you have tried. – fossfreedom May 11 '12 at 21:42
  • Sorry, for the delay. I removed all themes. I then installed the webupd8team/themes/ubuntu theme. Rebooted and still get the same issue except for the default theme. – chazdg May 12 '12 at 18:10
  • I am more convinced that this is an update that messed things up or a simple fix we are not aware of. I found another user in the ubuntuforums with the same issue. – chazdg May 12 '12 at 20:52

I've found how fix this:

It's in the gnome-shell.css file from the theme package. Some id definitions need the class name definition:


#notification {

Change to this:

#notification, .notification {

and some other definition... to sumup you have to compare with the gnome-shell.css file in /usr/share/gnome-shell/theme.

  • I'll have to take your word for it. Last week, updates hosed my system for no apparent reason. I dropped Mint for this very issue earlier this year. I re-installed 12.04 and it seems to be running fine (Unity and Gnome 3.4). Thanks for the info in case it should happen again – chazdg Jun 2 '12 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.