Eclipse uses Alt+F5 to Update Maven Project.

It's worked on earlier versions of Ubuntu, but on 20.10 that key combination is mapped to Un-maximize window, which is also what Super+ does.

I cannot find Alt+F5 under Settings → Keyboard Shortcuts, and I haven't figured out where these mappings are stored or how to change them outside the Settings app.

1 Answer 1


"Restore", which is found in the Windows section in Settings - Keyboard shortcuts, is not only assigned to Super+Down, but also to the "traditional" shortcut Alt+F5. You can disable the binding to Alt+F5 and retain the Super+Down binding:

  • Go to "Settings" - "Keyboard"
  • Click "View and customize shortcuts" in the right pane
  • Under the section "Windows", click "Restore window".
  • The "Set shortcut" dialog appears.
  • Press Super+Down: this will set that key only.

Alternatively, use gsettings in the terminal:

gsettings set org.gnome.desktop.wm.keybindings unmaximize "['<Super>Down']"

That removes the assignment to Alt+F5, but maintains Super+Down for unmaximizing a window. Reset to the default (['<Super>Down', '<Alt>F5']) with the command

gsettings reset org.gnome.desktop.wm.keybindings unmaximize

You can edit this and many other "hidden" settings using dconf-editor, not installed by default.

  • I'm going through and mapping modifier+F keys for maximizing capabilities to use in terminal (and unsetting them for gnome) and I found out that you can show that both Alt+F5 and Super+Down are bound to unmaximize by running gsettings get org.gnome.desktop.wm.keybindings unmaximize, it shows: ['<Super>Down', '<Alt>F5']. I think we can unbind Alt+F5, then, by simply going in and setting it to Super+Down (which seemingly would do nothing but should clear out Alt+F5).
    – Steven Lu
    Apr 17, 2021 at 0:33
  • 1
    Use gsettings set org.gnome.desktop.wm.keybindings unmaximize "[]" to remove binding
    – Vladislav
    Jul 7, 2021 at 12:31
  • thank you! this was breaking with vscode's "move to next/previous change" for me.
    – rmanna
    Apr 19, 2022 at 7:39
  • Thanks for the advice, it helped. It's even simpler to remove the binding, with just the standard configuration dialog. it's enough to set the binding again to the default value - Super Down. This will set it to just Super Down, removing the binding to Alt F5.
    – OndroMih
    Sep 22, 2022 at 9:53
  • Did you set the shortcut to Alt F5? I didn't mean to reset it to the default value, btu simply select the Alt+F5 shortcut for it. Maybe it's necessary to set another shortcut for it first, and then set it to Alt F5, but I don't think I had to do it. I simply selected the shortcut and pressed Alt + F5 on the keyboard.
    – OndroMih
    Sep 25, 2022 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.