I've messed up with repos. How do I get the default list of repos back? What about the keys I've probably have installed - but would not be used - if I'd roll back to the default repo list?


Here's the full story. On updating to Kubuntu 12.04 - virtuoso-t started to give some error (it kubuntu tells me that is crashes on start up). I thought - re-installation would solve the problem. So I made a complete re-installation of nepomuk. I didn't notice - but it has also removed my kde! So on restart I've login to Gnome session. So I get to the Internet, opened a synaptic - and tried to install kubuntu-desktop. But it turns out to be a some dependency problem - nobody were to provide a plasma-desktop libs and so on. So I used the ubuntu repos generator (link is in the answers - I always get there by googling). But it didn't help. Finally I found a machine with Kubuntu 11.10 - I've started an update process - have waited until /etc/apt got updated, took it to my machine - no luck again: dependecy problems. Finally adding:

sudo add-apt-repository ppa:kubuntu-ppa/ppa 
sudo add-apt-repository ppa:kubuntu-ppa/backports 
sudo add-apt-repository ppa:kubuntu-ppa/beta 

have solved it all.

  • Earlier: askubuntu.com/questions/124017/… – user26687 May 5 '12 at 17:06
  • yes... but keyserver.ubuntu.com is kind of dead... – Adobe May 5 '12 at 17:19
  • @Adobe keyserver.ubuntu.com is up on ports 80 and 11371. Are you sure that you don't have a firewall issue? What exactly do you mean by "messing up repos"? Installing third-party PPAs? – Lekensteyn May 5 '12 at 17:48
  • @Lekensteyn: cat /etc/services | grep 80 gives http 80/tcp www # WorldWideWeb HTTP. Does it mean the the port 80 is open? – Adobe May 6 '12 at 12:05
  • You cannot conclude that, /etc/services is used for mapping ports with their descriptive name. – Lekensteyn May 6 '12 at 12:48

Here's a great site that will give you a listing of the defaults based upon your country and version in use:


  • I know the link. I tried it - after adding it all - I had some dependency problem issues - and could not install kubuntu-desktop. – Adobe May 6 '12 at 11:29
  • And here's a link - where it says how can You add the keys - if You can't make it using keyserver.ubuntu. – Adobe May 17 '12 at 5:40

A quick and dirty solution, open bash_history file from your home folder, not sure what's equivalent of this file in KDE, and look for the PPAs you added manually using sudo add-apt-repository

Then, use ppa-purge (install it using sudo apt-get install ppa-purge) to remove all those added PPAs that you've found in your bash_history file. For example, you've added Mozilla Security PPA using

sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa

Than you may use following command to remove the PPA and revert back to version of Firefox available in repositories of Ubuntu (12.04 in your case).

sudo ppa-purge ppa:ubuntu-mozilla-security/ppa

sudo apt-get update

Note: You'll not see the PPAs added manually from update manager, as bash_history is nothing but a log of all the commands you've executed in terminal since your installation. But you can use it to keep track if things you've performed using terminal (like adding PPAs).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.