1

I am installing Lubuntu on old desktop PCs, a mix of 64 and 32 bits architectures. I installed Lubuntu 20.04 on the 64 bits PCs and like the UI, and would like the same on 32 bits where only 18.04 can be installed. As Lubuntu dropped LXCE since 18.10 for lxqt, I guess I need to install lxqt. But I cannot make any change on the UI: the lightDM GTK+ Greeter program supposedly allows to change theme and icons but none of the possible choices, either the ones installed with Lubuntu or other I installed, shows up, it remains always with the default theme and icon. Here is what the lightdm --show-config command shows:

   [Seat:*]
I  user-session=Lubuntu
J  allow-guest=false
L  greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
M  guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
N  xserver-command=X -core
P  greeter-session=kylin-greeter
Q  autologin-guest=false
Q  autologin-user=aic1
Q  autologin-user-timeout=0

   [LightDM]
K  backup-logs=false

Sources:
I  /usr/share/lightdm/lightdm.conf.d/20-lubuntu.conf
J  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
K  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
L  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
M  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
N  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
O  /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
P  /usr/share/lightdm/lightdm.conf.d/95-kylin-greeter.conf
I  /usr/share/lightdm/lightdm.conf.d/20-lubuntu.conf
J  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
K  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
L  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
M  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
N  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
O  /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
P  /usr/share/lightdm/lightdm.conf.d/95-kylin-greeter.conf

lightdm --show-config
  [Seat:*]
I  user-session=Lubuntu
J  allow-guest=false
L  greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
M  guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
N  xserver-command=X -core
P  greeter-session=kylin-greeter
Q  autologin-guest=false
Q  autologin-user=aic1
Q  autologin-user-timeout=0

  [LightDM]
K  backup-logs=false

Sources:
I  /usr/share/lightdm/lightdm.conf.d/20-lubuntu.conf
J  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
K  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
L  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
M  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
N  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
O  /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
P  /usr/share/lightdm/lightdm.conf.d/95-kylin-greeter.conf
I  /usr/share/lightdm/lightdm.conf.d/20-lubuntu.conf
J  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
K  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
L  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
M  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
N  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
O  /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
P  /usr/share/lightdm/lightdm.conf.d/95-kylin-greeter.conf


lightdm --show-config
 [Seat:*]
I  user-session=Lubuntu
J  allow-guest=false
L  greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
M  guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
N  xserver-command=X -core
P  greeter-session=kylin-greeter
Q  autologin-guest=false
Q  autologin-user=aic1
Q  autologin-user-timeout=0

 [LightDM]
K  backup-logs=false

Sources:
I  /usr/share/lightdm/lightdm.conf.d/20-lubuntu.conf
J  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
K  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
L  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
M  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
N  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
O  /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
P  /usr/share/lightdm/lightdm.conf.d/95-kylin-greeter.conf
I  /usr/share/lightdm/lightdm.conf.d/20-lubuntu.conf
J  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
K  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
L  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
M  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
N  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
O  /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
P  /usr/share/lightdm/lightdm.conf.d/95-kylin-greeter.conf
2
  • FYI: The LXDE devs themselves created the LXQt project (the port of LXDE to GTK3 was slow & heavy, they re-ported to Qt5 which was better so joining with Razor-Qt the new LXQt project was formed). LXDE -> LXQt is sort of natural progression with GTK2 EOL & GTK3 port abandoned (different people are trying it now). LXQt ran well in my opinion on i386 (18.10 & 19.04) but I'd not recommend using LXQt on bionic as it wasn't supported as an LTS with only 9 months package support as it wasn't deemed stable
    – guiverc
    Commented Mar 8, 2021 at 22:19
  • Thanks for your reply, I will create another thread regarding how to change the LightDM GTK+ settings
    – Severin
    Commented Mar 13, 2021 at 14:03

0

You must log in to answer this question.

Browse other questions tagged .