0

I'm a noob so please bear with me.

I am experiencing screen tearing using Ubuntu 20.4, which is a fresh install. I am using a laptop with Intel HD Graphics 530. I have a dedicated video card too, but I do not want to use that one as the default one.

So far I have tried to follow the steps here, but right after creating the 20-intel.conf file with "TearFree" set as "true", I rebooted my laptop and I was stuck in an endless login loop, so I am afraid of tinkering with it too much, because I had to reinstall Ubuntu 2 times already.

Any other suggestions? Thanks!

4
  • I suggest enabling your discrete GPU if you have it disabled. If your laptop has hybrid graphics, it was designed to use both the GPU and iGPU. Screen tearing is a common symptom of not having enough resources.
    – Nmath
    Mar 7, 2021 at 23:02
  • I have a dual boot system and on Windows 10 my integrated graphics card is used for displaying all graphics, except for games or Blender 3D. No screen tearing issues whatsoever. I'm suspecting it's a driver issue, but I have no idea where to even begin to sort out the issue without breaking my Ubuntu installation, lol.
    – hexoral333
    Mar 7, 2021 at 23:24
  • Have you installed ubuntu restricted extras package ?
    – Oppili
    Mar 15, 2021 at 16:42
  • I am not sure, tbh. Probably not? But basically Ubuntu was using my dedicated graphics card for whatever reason so I switched to the integrated one and screen tearing is gone. Then I switched back to the dedicated one out of curiosity and the screen tearing is gone. Super weird.
    – hexoral333
    Mar 16, 2021 at 21:52

2 Answers 2

1

I too had the issue after installing focal fossa. Later, I found that a very simple display setting was causing this problem.

For me, the fractional re-scaling display setting was causing the problem. Don't use this. Use large fonts and large icons, in case you wanted a slightly bigger screen content.

0

So basically what sorted it out was to first of all check in Settings > About what video card my system was using, and it was the Nvidia. I then typed "nvidia-settings" in the Terminal and I found an option that let me use my Intel graphics card. Screen tearing gone. Then I re-enabled my Nvidia card just to see what would happen and lo and behold, no screen tearing anymore. Weird.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.