I've recently installed Ubuntu 12.04 and I love it. However I have one problem- I am unable to shutdown or reboot properly.

When I shutdown my laptop (Acer Aspire 5560) it hangs on the 5 dots and stays there.

When I reboot my laptop it does shutdown but when it boots back up it stay's on the Purple screen (no logo what so ever)

Thing's I've I'd to stop this:

  • sudo service network-manager stop before shutdown - nothing

  • Adding some lines the the GRUB file - nothing

  • installed other Ubuntu versions - nothing
  • sudo shutdown -h now - nothing

and some more.

At the moment I see a black screen in front of me with the text

 Asking all remaining processes to terminate [OK]

And the 5 dots with only the last one orange.

On other tries I got this thing:

modem-manager:could not get the system bus......

I first had Ubuntu dual boot Windows. And then it worked fine. However after a fresh install of Ubuntu alone I got this.

  • 1
    Update: now got an error: "unmount: /run/lock: not mounted" "Will now halt"
    – Max Beer
    May 5, 2012 at 15:51
  • 1
    I think it has something to do with the power management on the Acer and the board is not getting the proper signal or misinterpreting the signal it gets. I've got the same model and working on the same issue.
    – user62033
    May 9, 2012 at 14:18
  • 1
    Update: installed other distros (mint, fedora) both work! This means it has something to do with ubuntu itself and not my laptop.
    – Max Beer
    May 11, 2012 at 19:21
  • I am experiencing the same problem on my Acer laptop. This was not like this before when I fresh installed Ubuntu. I guess an update must have caused this for me. Does the fixes suggested below work?
    – ultrajohn
    Sep 12, 2012 at 22:44

7 Answers 7


I had a similar problem with a Dell XPS 15z which I resolved by adding acpi=noirq to the kernel arguments:

sudo editor /etc/default/grub


GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"


sudo update-grub

Note that previously I had been using acpi=off, which permitted me to boot, but not shutdown. Without any acpi flag, I was not able to boot.

  • 1
    This did the trick for me, thanks. Running 12.04 64-bit on a Dell XPS M1530.
    – Gemini14
    Jun 29, 2012 at 23:35
  • How exactly do you update the grub? I mean when I type sudo vi /etc/default/grub the grub file appears in the terminal. But how do I edit it?
    – Della
    Jul 5, 2013 at 13:01
  • 1
    @Barman This link should help you keyxl.com/aaab462/105/VIM-Text-Editor-keyboard-shortcuts.htm
    – Keen Sage
    Aug 11, 2013 at 16:20
  • This didn't worked for me
    – Keen Sage
    Apr 30, 2014 at 9:01
  • Adding acpi=noirq fixed the reboot problem but also disable my builtin keyboard and mouse. I can only use my laptop using external mouse and keyboard. Jul 23, 2014 at 3:27

You may try to these commands into terminal

For shutdown:

sudo halt

For shutdown:

sudo init 0

For restart:

sudo init 6

For shutdown:

sudo shutdown -h now

For hibernate:

sudo /etc/acpi/hibernate.sh
  • Too bad, all failed. Still stuck on the ubuntu logo with 5 dots.
    – Max Beer
    May 6, 2012 at 9:15
  • 1
    These are all different ways of doing the same thing - the thing that the OP said didn't work.
    – jwg
    Jun 4, 2015 at 21:16
  • None of these work because they're all pretty the same thing for shutting down. It was a different problem. Dec 4, 2016 at 16:16

I got a hack from this link -- http://www.pbehnke.com/main/node/11, for some reason if the usb controls are set to auto, the shutdown-reboot loop starts. The solution was to make them on forcefully.

I have added a function in the /etc/init.d/halt script like this --

# Add this function in the /etc/init.d/halt script
# call before do_stop
set_usbs_on () {
    for dev in $usbcontrolpath;
        echo "Setting $dev: " `cat $dev` "to on"
        echo on > $dev
        echo ""

and I call it before do_stop in case $1 stop switch --


Now the machine shuts down.

  • this was working. at some point it has now stopped working (don't know when as the computer is generally on 24/7). if you execute in a terminal then first then poweroff will work. if you don't then machine reboots (kubuntu 15.04 / asus z68 / i5-2500k) Jun 20, 2015 at 16:24
  • yes, if you execute the commands on the terminal it will work only for that session. To make it permanent, you need to modify the /etc/init.d/halt file as described above.
    – ramgorur
    Jun 22, 2015 at 8:03
  • the code is in /etc/init.d/halt and has been all the time (both when it worked and since it has stopped working). since found out that the halt service is masked. just have to fathom out how to unmask it as systemctl umask halt does not appear to be working Aug 16, 2015 at 23:02
  • It works well, but since ubuntu 15.10 onwards made systemd as default... it works only after "Permanent switch back to upstart". wiki.ubuntu.com/SystemdForUpstartUsers Nov 15, 2015 at 6:37

The only thing that I needed to do was to press Ctrl+Alt+T to open the terminal. When it opens, run the command below

sudo update-grub

and now it's working fine.


Same issue with spurious hangs "on the 5 dots". I've read somewhere (cannot remember where) to first "Log Out" (top right corner menu) and then shutdown. I've been doing this for more than one month now with no more issue.


I'm no expert but i loaded BARTpe to get to a command promt and reinstalled bios it booted straight to the hard drive guess it couldnt see it just try to load default in your bios might not have to update

  • What do you mean by "reinstalled bios"? What exactly did you do?
    – MadMike
    Jan 20, 2015 at 9:13
  • 1
    Just to serve as a slight explanation, BARTpe is a bootable Windows environment, which by extension would allow you to run BIOS firmware patchers which are commonly Windows-only applications. I'm not sure how that would help but that's what is being suggested here.
    – Oli
    Jan 20, 2015 at 11:35

I realize this is a super old post, but I found the REAL answer for this model. It's not Ubuntu, it's the Aspire.

From the ubuntu bug registry: (link)

It seems that is BIOS/UEFI bug, so there is no solution to fix it on 5560g if planning use efi.

A user on TomsGuide confirms this is the case even when installing Windows:

The problem is, that the ACER Aspire 5560G model somehow (don't ask how {maybe BIOS related?}) can't shut down properly (freeze) when the OS is installed in a GPT partition style.

Again from the bugs page a workaround: (link)

WORKAROUND: using gdisk convert gpt to mbr, setup boot-repair, restore mbr and then restore grub

Lot's of work to fix such a small thing. Some users have suggested that a BIOS update my help.

DISCLAIMER: I cannot confirm any of this outside that the error occurs, and that windows does indeed experience the same issues when installed with gpt. If I do decide to follow the workaround (very risky) or update the BIOS (even more risky) and get some further results I'll update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .