1

Using network-manager-openconnect & network-manager-openconnect-gnome I have set-up a Palo-Alto Networks GlobalProtect VPN to connect to my company network.

This works fine and I can access all internal company websites. However I would like this VPN to only be active for company domains and addresses so I've tried setting up routes like this Route configuration But when I apply these changes and connect to the VPN I can't navigate to any of the company pages. When I try I get a This site can't be reached with DNS_PROBE_FINISHED_NXDOMAIN error in chromium. Oddly enough I can ping the IP addresses of these sites. Just the IP's, domains do not work.

This brought me to believe that there's a problem with DNS resolving so I tried adding the DNS server addresses to the DNS field and switching Automatic to off but that did not help.

What could I do to diagnose this issue? I feel like I am close to have it working but I am stuck.

0

Oh, you're going to love this: Chromium (and Chrome) will bypass your preferred DNS when connected to the open web to use their "secure DNS" services. You can disable this on Mac and Windows so that the "Use this connection only for resources on its network" is followed, but not Linux.

To illustrate this on Mac via Settings ⇢ Search "DNS":

macOS — Use Secure DNS

Your Options

  1. If you are 100% wedded to Chromium, all traffic will need to go through the VPN. Uncheck the "Use this connection only for resources on its network" option from the VPN settings.
  2. If you want to use something like Chromium, consider switching to Edge, which does allow you to disable the "secure DNS" function as illustrated here: Microsoft Edge - Secure DNS
  3. Use Firefox

Hopefully one of these options will work for you 👍

1
  • Thanks for the reply! I've tried both Edge with secure DNS disabled and Firefox but still no luck. I can open up Youtube or StackOverflow but I can't connect to the company site even though i can ping it's IP. – MrPlow Mar 8 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.