Ok, I have 4 computers all running Ubuntu 12.04 with Gnome Shell. on all computers when ever I play games in wine I set wine to run in a virtual desktop. On the first 3 computers I can use things like "Alt-Tab" and I can use the "Super/Windows" key to get into overview mode while playing games and it functions absolutely flawless, I can even move the game to another deaktop and continue playing. However on the 4th Computer neither "Alt-Tab" or "Super" Do anything, as a matter of fact if I hit them more than once the window will loose focus and I have to shutdown to get out of the game. I also noticed on the 4th computer that the Volume popup for Gnome Shell doesnt diplay either, but it does on the other 3.

All 4 Computers are running Ubuntu 12.04 (fully up-to-date), and they are all running Gnome Shell (Fully up-to-date from the offical Gnome 3 PPA). All Computers have thier respective proriatary graphics drivers installed.

1st: Works Fine AMD CPU and AMD Radeon HD6850 Graphics

2nd: Works Fine AMD CPU (mobile) and AMD Radeon HD 6520G graphics

3rd: Works Fine (Only PC running 32bit Ubuntu) AMD CPU and Nvidia GeForce GTS 250 graphics

4th: Doesnt Work AMD CPU and ATI Radeon HD4850 graphics

EDIT: A friend of mine is also running 12.04 64bit with Gnome shell and a Radeon HD 4850, he is also not able to do this either. Could it be something specific to the HD4850? I can do it just fine on my HD 6850.


For most games running on wine, alt tab start working only when you set (in 'winecfg') compatibilty to windows 7.

  • Thanks for the tip, I switched it over to Windows 7 and it still does not work. However it did help with it loosing focus. I'm updating my original post with some new info I found. – Relik May 7 '12 at 21:17

From my experience, switching out of fullscreen 3D applications (games) works flawless with the open source radeon drivers but does not work at all with the proprietary ATI/AMD fglrx drivers.


For me the solution was enable virtual desktop in wine config using the resolution of my pc, for example in my notebook I set the resolution to 1366x768 and used Alt+Tab to go back to game. I must press Alt, if I don't the letters won't work correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.