I bought an Bluetooth adapter that says it is Linux compatible. The Bluetooth rune shows in the tool bar I open the Bluetooth devices window via the rune and it shows the device I wish to connect to. When I tell it to connect as serial device the bubble simply bounces back and forth forever.

Using Ubuntu 20.04 LTS.


Bus 002 Device 003: ID 19ff:0239 Dynex BCM20702A0


I updated all updates and now I get a window on log-in saying "system error" about Bluetooth tray. I went syslog to find more details.

Log says: firmware patch file not found.

[   12.340873] Bluetooth: Core ver 2.22
[   12.340901] Bluetooth: HCI device and connection manager initialized
[   12.340906] Bluetooth: HCI socket layer initialized
[   12.340907] Bluetooth: L2CAP socket layer initialized
[   12.340912] Bluetooth: SCO socket layer initialized
[   12.672664] usbcore: registered new interface driver btusb
[   12.799986] Bluetooth: hci0: BCM: chip id 73
[   12.810958] Bluetooth: hci0: BCM: features 0x07
[   12.850090] Bluetooth: hci0: godbless
[   12.850097] Bluetooth: hci0: BCM20702B0 (002.001.014) build 0607
[   13.054492] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[   13.054540] Bluetooth: hci0: BCM: 'brcm/BCM20702B0-19ff-0239.hcd'
[   13.054572] Bluetooth: hci0: BCM: 'brcm/BCM-19ff-0239.hcd'
[   25.267365] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   25.267368] Bluetooth: BNEP filters: protocol multicast
[   25.267373] Bluetooth: BNEP socket layer initialized
[   41.793203] Bluetooth: RFCOMM TTY layer initialized
[   41.793210] Bluetooth: RFCOMM socket layer initialized
[   41.793219] Bluetooth: RFCOMM ver 1.11

Edit again

I downloaded the files as suggested and the log message about missing file is gone, however my device still will not connect.

There is now two Bluetooth runes in the tray.

image of tray


2 Answers 2


Those files are not (yet) in the linuxfirmware package, so try getting them from github:

Copy the downloaded hcd file(s) into /lib/firmware/brcm And reboot to see if they are picked up.

  • 1
    You can use dmesg command to see which firmware you need to copy to /lib/firmware/brcm. Then re-plug the bluetooth adapter. You should see that the copied firmware was successfully loaded via dmesg command again. May 11, 2021 at 10:07
  • 3
    now they have .deb and .rpm: github.com/winterheart/broadcom-bt-firmware#installation
    – JOduMonT
    May 22, 2021 at 10:15
  • you solution finally helped me use my laptop bluetooth device,thank you Mar 31, 2022 at 17:00

I tried many of the solutions here but noting seemed to work for me and I'm certain there are also people here who are in the same situation

What solved it for me was installing the broadcom-bt-firmware deb file from the repo here you can also check the repo for other Linux distribution specific installation formats here

I believe this would also solve problems like those asked here and here

Just install the package and restart your PC, this fixed it for me on two occasions and I believe should also fix it for anyone with the same or similar issues

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .