0

I have just bought a new Lenovo laptop. I've installed the Ubuntu 20.04, but my touchpad doesn't work.

Here is the result of xinput command:

output of xinput

Do you have any idea how to fix it?

1
  • A little more info will be required. Which Lenovo do you have? They make a lot of devices. You had mentioned that you've tried many things, but could you outline some of the fixes you've tried that have failed? This will allow someone to offer a possible solution that you have not tried that will work for you specific Lenovo 👍🏻
    – user1091774
    Commented Mar 3, 2021 at 15:09

4 Answers 4

0
  1. $xinput shows the available input devices in the machine. but, the machine hava a data for it. So,Maybe it is hardware(touchpad) problem.
  2. Maybe Hardware is good,just reboot and try any other OS.
  3. else, see the settings for touchpad(Settings > mouse and touchpad> touchpad) is enable/disable. Many lenovo laptop's F6(function key) for enable or disable touchpad.
0

I have a Lenovo t420 that has touchpad problems. I run this script at startup:

DEVICENUM=$(xinput | grep SynPS/2 | grep 'id=' |  cut -d= -f2 | cut -b 1,2)
printf "\033c"
xinput set-prop $DEVICENUM "Device Enabled" 0
xinput set-prop $DEVICENUM "Device Enabled" 1
echo "done"
3
  • do you have to run this everytime? Commented Mar 13, 2021 at 7:06
  • I run in at startup with a chron, yes. Commented Mar 13, 2021 at 22:13
  • That is strange because I had a T420 Thinkpad and never had issues with the touchpad but now with an Ideapad the touchpad is not even recognized. Commented Mar 13, 2021 at 22:56
0

sudo gedit file /etc/default/grub

Replace line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="pci=nocrs quiet splash"

Save file /etc/default/grub

Execute update-grub

Reboot

As it's commented here

lenovo IdeaPad-3-14ARE05 Touchpad not working. Ubuntu 20.04

It works for me on 20.04

0

I have Ubuntu 20.04 and I have faced the same problem. My touchpad was not working after changing my OS from Windows 11 to Ubuntu 20.04/18.04. In Settings, only the mouse options were visible, not the touchpad ones.

If the problem is with your hardware, you must visit the nearby customer care service. If it's not a hardware issue, then there is no problem with your drivers also.

All you need to do is just make a small change on your default /etc/default/grub file. That's how I resolved the problem. Follow these steps:

  1. Open a terminal.

  2. Run the following command:

    sudo gedit file /etc/default/grub
    
  3. The /etc/default/grub text file will be opened. If it is empty, navigate to its adjacent tab.

  4. Replace the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    with:

    GRUB_CMDLINE_LINUX_DEFAULT="pci=nocrs quiet splash"
    
  5. Click on Save and return to the terminal.

  6. Run the following command:

    sudo update-grub
    
  7. Reboot.

Your issue will be resolved. Your touchpad will be working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .