4

The resolution of my PC is 3200x1800 but I have enabled 2x scaling on my Windows and Linux machines.

When I connect using Workspace app from my Windows machine then the resolution of my remote PC is appropriately set to 1600 x 900. But when I connect from my Ubuntu machine then the resolution of remote PC stays at 3200x1800 and as a result I see very small text.

What do I need to do to ensure that my remote PC is scaled properly?

I am running the latest packages "Citrix Workspace app for Linux (x86_64)", downloaded from: https://www.citrix.com/downloads/workspace-app/linux/workspace-app-for-linux-latest.html

2
  • I believe there is no direct solution to this problem with the linux citrix client. The only workaround I found was to install Citrix in a Virtual Box virtual machine and then use the autoscaling option of virtual box.
    – jomuller
    Commented May 19, 2021 at 8:04
  • The question was ask here too "Change DPI setting for Citrix Receiver" and lead to the same kind of workaround I suggested: VirtualBox or using VNC (but I didn't try the later). A bug report should be send to Citrix in this subject.
    – jomuller
    Commented May 21, 2021 at 5:34

3 Answers 3

1

The best solution I have found is to use Google Chrome and install the Citrix Workspace Chrome App. DPI scaling is much better.

0
0

Had a similar issue. Turns out the problem comes from fractional scaling setting in "Display Settings". So simply turning off "Fractional Scaling" fixed the issue for me

Instructions on how to enable/disable "Fractional Scaling" can be found here

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Apr 27, 2023 at 10:06
0

Try setting DPIMatchingEnabled=True in your $HOME/.ICAClient/All\_Regions.ini file

This worked for me when I had the same problem (although I am using Ubuntu 22.04)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .