I've tried installing Sun JDK from sudo add-apt-repository ppa:eugenesan/java, it failed with the following:

--2012-05-05 15:50:09--  http://download.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-x64.tar.gz
Resolving download.oracle.com (download.oracle.com)...
Connecting to download.oracle.com (download.oracle.com)||:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-x64.tar.gz [following]
--2012-05-05 15:50:09--  https://edelivery.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-x64.tar.gz
Resolving edelivery.oracle.com (edelivery.oracle.com)...
Connecting to edelivery.oracle.com (edelivery.oracle.com)||:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/errors/download-fail-1505220.html [following]
--2012-05-05 15:50:09--  http://download.oracle.com/errors/download-fail-1505220.html
Connecting to download.oracle.com (download.oracle.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5307 (5.2K) [text/html]
Saving to: `./jdk-7u3-linux-x64.tar.gz'

     0K .....                                                 100% 20.5M=0s

2012-05-05 15:50:09 (20.5 MB/s) - `./jdk-7u3-linux-x64.tar.gz' saved [5307/5307]

Download done.
sha256sum mismatch jdk-7u3-linux-x64.tar.gz
Oracle JDK 7 is NOT installed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:

So apparently it's trying to fetch a bad URL. I've installed Java manually, but now the package is stuck as a half-installed and every time I apt-get install anything, the error appears again.

apt-get install -f shows "1 not fully installed or removed." package and fails with the same error. I've tried dpkg -P oracle-java7-installer, but it fails as well.

How to remove this half-installed package?


Awww yeahh.. I've been able to finally remove after finding this post the following way: sudo find /var/lib/dpkg -exec grep -l "oracle-java7-installer" {} \; showed a bunch of files, I've added exit 0 to first line by typing sudo gedit /var/lib/dpkg/info/oracle-java7-installer.prerm, saved file and closed gedit. Finally, after I was back on command line, typed sudo dpkg -P oracle-java7-installer and it worked.

| improve this answer | |
  • By the way, if you want to fix the half-installed package rather than manually installing Java, the answer here should facilitate that. – Eliah Kagan May 23 '12 at 14:33
  • Worked fine! In my case I had to edit /var/lib/dpkg/info/oracle-java8-installer.postinst and add an exit 0 there. – user334639 Aug 13 '15 at 2:07

sudo rm /var/lib/dpkg/info/oracle-java7-installer*

sudo apt-get purge oracle-java7-installer*

sudo rm /etc/apt/sources.list.d/java

sudo apt-get update

sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-java7-installer

| improve this answer | |
  • I would love to work out how I get to know to look for that first line. It's bugged me for weeks – Madivad Jun 6 '17 at 14:01

Use 'Synaptic Package Manager' to remove OR fix broken packages

To download and install 'Synaptic Package Manager' type the following command in the terminal >>

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install synaptic
| improve this answer | |
  • Does not work. Marked the package for removal, clicked "apply" - the package is still there. I'm guessing it gets the same error – Fluffy May 5 '12 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.