2

Check this image

In the above image you can see how much space is there. My complete cursor can fit above close button. I don't want that. I want to close any app by clicking on the extreme top right corner without aiming on close button every time. Right now, whenever I move the cursor to corner, I always end up clicking on the title bar in the corner.

I tried to copy paste some settings I found on the internet into ~/.config/gtk-3.0/gtk.css using:

gedit ~/.config/gtk-3.0/gtk.css

But that made the height of title bar with the close button very large, still keeping the space in corner, as the button is a circle. I have zero experience with programming, so I don't know what other settings to change.

Other things I tried:

  • First I used the Unite extension to get the close button in the top bar. Then I realized that I am not able to switch tabs in Mozilla Firefox by moving cursor the to the extreme top, because at the top there is the top bar.

  • Then I tried the Hide top bar extension. It made more mess. Sometimes I managed to click on the Mozilla Firefox tab from the top and sometimes I ended up clicking on the top bar.

  • So I had to get rid of the top bar. I did that using Dash to panel. Now I get that Windows 10/KDE feel. With the top bar at bottom now, the Unite buttons are also at bottom. I still have the close button in title bar of window right, but it's not at its extreme corner when window is maximized! So I still have to aim on it.

I had same problem in Manjaro KDE, but only when I changed the theme. However, in Ubuntu this is also the case with the default theme.

So any suggestions please? (Please don't suggest changing the display scaling as it makes the application window a lot bigger.)

3
  • Bruh, have you tried using a binding like Alt-F4?
    – Figaro
    Mar 1 '21 at 19:24
  • Yeah ! I know alt +F4. But I put my keyboard away while eating 😅. Mar 2 '21 at 3:56
  • Another similar question with no answer: askubuntu.com/questions/1301188 . I am also searching for an answer to this! :( I tried to make the title bar smaller as explained in: unix.stackexchange.com/questions/276951/… - This solved the problem for some applications, but not for Nautilus File Manager.
    – FedKad
    Mar 5 '21 at 11:17
0

As I explained in the comments to your question, this answer at Stack Exchange tries to make the "headerbar" a little narrower, so the buttons come closer to the top of the screen. I also managed to make the "close" (×) button a square instead of a circle, by adding the following code to the end of file ~/.config/gtk-3.0/gtk.css and restarting GNOME (to do this, press Alt+F2 and type r followed with Enter):

headerbar {
  margin: 0px;
  padding: 0px;
}

headerbar button.titlebutton.close {
  min-height: 48px;
  min-width: 48px;
  margin: 0px;
  padding: 0px;
  border-radius: 0px;
}

This solves the problem for some applications, but not exactly for all, since it seems that some applications use extra wide "headerbar"s. Please, test and make the necessary modifications that fit your current settings.

Also, note that, some already running applications with open windows may not reflect the CSS changes immediately after you restart GNOME. You may have to restart those applications or even log out and log in for the changes to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.