0

I'm running Ubuntu 20.04 and wants a VM with another install of Ubuntu to try out some stuff.

I've installed VirtualBox as describes on their website (added ppa) and followed this post on how to install it.

When I try to boot it up I get a popup saying the following:

Error message

So... I've tried to search the forum, but like this post they doesn't describe their problem in detail and the last post doesnt seem to be my problem. I have 16 GB of ram.

However when I look into the logs I see that there's a problem reading the ISO and the VM Disk:

00:00:00.794924 VirtualBox VM 6.1.18 r142142 linux.amd64 (Jan  7 2021 17:36:17) release log
00:00:00.794926 Log opened 2021-02-27T10:46:27.374821000Z
00:00:00.794926 Build Type: release
00:00:00.794929 OS Product: Linux
00:00:00.794930 OS Release: 5.8.0-44-generic
00:00:00.794931 OS Version: #50~20.04.1-Ubuntu SMP Wed Feb 10 21:07:30 UTC 2021
00:00:00.794947 DMI Product Name: 20KFCTO1WW
00:00:00.794952 DMI Product Version: ThinkPad X280
00:00:00.794957 Firmware type: UEFI
00:00:00.795549 Secure Boot: Enabled
00:00:00.795583 Host RAM: 15760MB (15.3GB) total, 10827MB (10.5GB) available
00:00:00.795586 Executable: /usr/lib/virtualbox/VirtualBoxVM
00:00:00.795586 Process ID: 27519
00:00:00.795587 Package type: LINUX_64BITS_UBUNTU_19_10
00:00:00.806297 Installed Extension Packs:
00:00:00.806323   None installed!
00:00:00.807016 Console: Machine state changed to 'Starting'
00:00:00.807171 Qt version: 5.12.8
00:00:00.807192 X11 Window Manager code: 2
00:00:00.810712 SUP: seg #0: R   0x00000000 LB 0x0004c000
00:00:00.810778 SUP: seg #1: R X 0x0004c000 LB 0x00114000
00:00:00.810823 SUP: seg #2: R   0x00160000 LB 0x0005f000
00:00:00.810831 SUP: seg #3: RW  0x001bf000 LB 0x00035060
00:00:00.812782 SUP: Loaded VMMR0.r0 (/usr/lib/virtualbox/VMMR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX
00:00:00.812819 SUP: VMMR0EntryEx located at XXXXXXXXXXXXXXXX and VMMR0EntryFast at XXXXXXXXXXXXXXXX
00:00:00.814081 Guest OS type: 'Ubuntu_64'
00:00:00.815672 fHMForced=true - No raw-mode support in this build!
00:00:00.819263 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:00.820811 X Server details: vendor: The X.Org Foundation, release: 12009000, protocol version: 11.0, display string: :0
00:00:00.820842 Using XKB for keycode to scan code conversion
00:00:00.821575 File system of '/home/joachim/Downloads/ubuntu-20.04.2.0-desktop-amd64.iso' (DVD) is unknown
00:00:00.823308 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 0 work area is actually resized to: 48x27 x 1872x1053
00:00:00.826613 File system of '/home/joachim/VirtualBox VMs/Ubuntu Eoan/Snapshots' (snapshots) is unknown
00:00:00.826651 File system of '/home/joachim/VirtualBox VMs/Ubuntu Eoan/Ubuntu Eoan.vdi' is unknown
00:00:00.838188 Shared Clipboard: Service loaded
00:00:00.838223 Shared Clipboard: Mode: Off
00:00:00.838267 Shared Clipboard: Service running in normal mode
00:00:00.838949 Drag and drop service loaded
00:00:00.838972 Drag and drop mode: Off
00:00:00.840708 ************************* CFGM dump *************************

Lines like these:

00:00:00.826651 File system of '/home/joachim/VirtualBox VMs/Ubuntu Eoan/Ubuntu Eoan.vdi' is unknown

I've tried to install the extension pack without any luck.

My host system uses ZFS. Could this be related?

Anyone else experienced this and maybe solved it somehow?

1
  • Read somewhere that a dynamic VDI could be problematic with ZFS and tried fixed size without any difference. – Joachim Feb 27 at 11:05
1

So, it turned out to be a GUI issue. Found a line containing the following in the logs

Argument aWidth is invalid (must be aWidth != 0 && aWidth <= 32767)

And then ran

vboxmanage setextradata "Eoan" "GUI/LastNormalWindowPosition"

in the terminal (Eoan is the name of the VM instance), re-opened VirtualBox and everything booted smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.