0

i installed bumblebee to switch between GPU but when i run the commande optirun i get the following message [ 97.796880] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nvidia" (module does not exist, 0)

[ 97.796906] [ERROR]Aborting because fallback start is disabled. i have installed the nvidia drivers, but the GPU declare itself as 3d controller not VGA compatible 06:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX250] (rev a1) 00:02.0 VGA compatible controller: Intel Corporation Iris Plus Graphics G7 (rev 07)

1 Answer 1

0

I had the exactly same problem today. Here's a quick way I solved it:

  1. Open /etc/bumblebee/bumblebee.conf
  2. Find the line that begins with XorgModulePath and change it to:
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules,/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules/input
  1. Save the file and restart bumblebeed:
sudo systemctl restart bumblebeed

This solution should work for similar errors where a mouse module is missing.

6
  • i did it and now i receive this error Feb 27, 2021 at 8:08
  • [GFX1-]: No GPUs detected via PCI [GFX1-]: glxtest: process failed (received signal 11) Feb 27, 2021 at 8:08
  • @aminekhazraj You should try the GPU without bumblebee first. Try sudo prime-select nvidia, then reboot and open the NVIDIA X Server settings. To switch back, use these commands: sudo prime-select intel && sudo rm /lib/modprobe.d/blacklist-nvidia.conf && sudo update-initramfs -u. Again, reboot after switching the GPU. To use bumblebee, the Intel GPU must be selected with the blacklist-nvidia file removed.
    – adazem009
    Feb 27, 2021 at 9:24
  • @aminekhazraj I just got this error too. Which program did you launch with optirun? For me, it only happens with programs like Firefox. Try optirun glxgears (install glxgears first). If you see the gears spinning, you should be fine.
    – adazem009
    Feb 27, 2021 at 10:02
  • I did the first steps and now the laptop won’t turn on Feb 28, 2021 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.