1

I use Firefox on Ubuntu.

I installed espeak.

When I use Narrate, Firefox reads a text with robotic espeak voices.

I installed Mbrola with french voices.

I can use espeak + mbrola on cli:

espeak -v mb/mb-fr1 "parlez vous français ?"

And get more realistic voices.

But firefox only uses espeak voice.

How to force Firefox narrate to use Mbrola voices?

1
+50

To have more realistic voices with Firefox you could use festival, instead of mbrola. It has quite a few sets of voices available.

You could even use festival with mbrola voices.

The interface between Firefox and speech-dispatcher seems not robust. Current state of affairs may have evolved a bit, I am not able to test now. YMMV.

Related:

  1. How can I change the voice used by Firefox Reader View (Narrator) in Ubuntu?
  2. https://bbs.archlinux.org/viewtopic.php?id=237718
1

It is possible to put the Espeak/Mbrola voice by modifying the /etc/speech-dispatcher/speechd.conf file.

We need to Uncomment this line:

AddModule "espeak-mbrola-generic"    "sd_generic"   "espeak-mbrola-generic.conf"

And change parameter DefaultModule from espeak-ng to espeak-mbrola-generic

DefaultModule espeak-mbrola-generic
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.