0

Some necessary background:

About a month ago I changed my daily driver from Windows to Ubuntu. I am using 20.04 LTS. neofetch On my daily Zoom calls however, people were constantly complaining that my audio (using my laptops internal mic) was noisy and they could only hear my first few words. I tried Pulseauido's echo-cancel feature with no luck, then I tried to use blueman-bluez to get Apple's Airpods connected on Ubuntu in HSP/HFP mode instead of A2DP with no luck. Finally I had enough and bought an external microphone that I plugged into my computers combined speaker/microphone jack only to realize that it is not possible to get input from a jack and output from an internal speaker on Pulseaudio's GUI.

I followed several tutorials and installed several ALSA and Pulseaudio tools (maybe even a random repository I found on the internet) in hopes of getting my audipo working. Eventually I did get the microphone input working using some simple commands (pacmd list-sources and pacmd set-default-source [in config file]). Throughout the process I have purged, removed, and reinstalled ALSA, ALSA-utils, Pulseaudio, pulsemixer, pavucontrol several times.

The problem:

At this point when I try to connect any Bluetooth audio device to my computer, I encounter some weird issues. I have restarted bluetooth, pulseaudio, and ALSA using the proper commands.

Device tries to pair and blue circle appears then it changes to not set up: Blue circle

After several tries, it will freeze. Then the device might pair and the connection slider instantly goes to off: Connection slider

At this point if I restart the device will connect, however if I switch from Bluetooth to sound settings, the device will not appear under output devices: Sound settings

The only thing that does appear here are "Speakers - Built-in Audio" - which work fine by the way. Also the only thing available under configuration is Analog surround 4.0, Analog Sound 2.1, and Analog Stereo Output. I have tried to reinstall all sound and Bluetooth utilities from scratch and restarting several times with no luck. What could the issue be and why didn't several complete reinstalls of Pulseaudio and ALSA solve it?

1
  • Lose the pics from the question they add nothing. – David Feb 26 at 7:24
1

Solution from OP: The problems were caused by the devices being stuck under bluetooth as paired devices erroneously. After finding out the MAC addresses of the devices using bluetoothctl and removing them using remove [MAC address] devices could be paired again without issues.

For example, run the command

bluetoothctl

You will get a new prompt [bluetooth]#. You can type help for a list of commands. The command devices should return details of available devices, for example (here I'm making up a dummy MAC address):

[bluetooth]# devices
Device AA:BB:CC:D1:E2:33 Audio Thingy

The string full of colons is the MAC address. To remove this device (put the correct MAC address found by the previous command:

remove AA:BB:CC:D1:E2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.