I have a machine with Windows 7 and Ubuntu 11.10

In Ubuntu I have about 30% packet loss when I make pings either to my router gateway or to an external site such as google.com, so my internet connection goes very slow.

Since the network works perfectly fine in Windows 7 (without any packet loss), I assume it's not a problem of the line.

Is there anything I could change in network settings or something similar in order to make this work correctly in Ubuntu?

I edit to say that I found my solution here (the problem was defective realtek drivers):

How do I stop my ethernet network connection from dropping?

  • not sure on this - but could this be a MTU issue? askubuntu.com/questions/59335/…
    – fossfreedom
    May 9, 2012 at 21:09
  • Does this happen from a liveCD? What did you change from a vanilla install (bonding or virtual interfaces or custom settings)? Wired or wireless?
    – belacqua
    May 10, 2012 at 4:30
  • MTU? IPv6? Why don't you use a packet sniffer to find out what gets dropped? My guess would be your Ubuntu is auto-configured for IPv6, but the router has no clue of how to handle it. May 10, 2012 at 12:40
  • please, post us the result of "ifconfig -a" after you had your 30% loss. May 13, 2012 at 12:46

3 Answers 3


I have experienced Packet Loss in Ubuntu, too under two circumstances:

  1. Routing Issues when having multiple Interfaces in the same Network I had two LAN Ports in the same network and the I suppose the routing of both interfaces overlapped and they took turns in sending/receiving from and to the network. The problem stopped as soon as i disabled one interface

    $ sudo ifconfig eth1 down
  2. Connections are timing out because they tried to use IPv6 at times Especially when doing DNS Requests while apt-get updating some repositories, even official ubuntu ones, cannot be resolved to an ip.

    See https://help.ubuntu.com/community/WebBrowsingSlowIPv6IPv4 in this case.

Also you should give more information, like complete output of both

$ ifconfig


$ route

Under no circumstances should you need to remove network-manager or any other preinstalled network management software. They work just fine, when configured correctly.

I'm sorry that both points are rather blurry, but I guarantee, that both happened as I told them.


There is a similar problem like you and there a solution to it says:

I finally managed to download wicd with much pain and patience and I'm happy to report it is much better now. It works good enough to browse the web and post this although it is too early to say it's it is back 100%. The problem must have been with the network manager package.

and here is the link to the problem.

  • I have removed the network-manager and installed wicd but the problem remains the same.
    – rfc1484
    May 5, 2012 at 21:05
  • try changing network ports and restart network settings
    – ashutosh
    May 5, 2012 at 21:21
  • If by that you mean changing my network configuration in order to use a static IP, I have already tried that but to no avail. If you mean another thing please clarify a little if you could.
    – rfc1484
    May 6, 2012 at 6:53
  • I just mean that it could be the network port problem. Try to reconnect the laptop to the network
    – ashutosh
    May 6, 2012 at 10:33

I have had earlier versions of Ubuntu fail to get along with older router firmware. Check to see if your router is older and there is newer firmware available. You can find instructions on the internet to update this. You need to type your routers IP address into the URL bar with a web browser (there is a manufacturers default IP address for your model number). If you do not have the username and password than you will need to find the manufacturers default credentials from on the web as well. If you still cannot get in, than reset your router (small push button somewhere) and than try the default login credentials again. There should be a update button/menu in the UI somewhere to automatically update (you may need to download the file for it to update with).

NOTE: If your router has been configured, any changes to the router will be permanent. You can only go back to the manufactuaers defaults with the reset button. Any of your current deviations from the default settings will be lost!

  • I have updated the firmware to the latest version but the problem is still there.
    – rfc1484
    May 10, 2012 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.