1

I just added a VL805 PCIe card to my 20.04 system, and while it's found, and a driver (xhci_hcd) is allocated to it, it is not working.

This is the output from lspci -k:

28:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)
        Subsystem: VIA Technologies, Inc. VL805 USB 3.0 Host Controller
        Kernel driver in use: xhci_hcd

The symptom that I have found so far is that in dmesg, there are several entries reporting that this device is found, and is being configured, but then later on, there is this entry:

[  117.733492] xhci_hcd 0000:28:00.0: WARNING: Host System Error
[  117.733534] xhci_hcd 0000:28:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0012 address=0xd245d000 flags=0x0000]
[  117.749501] xhci_hcd 0000:28:00.0: Host halt failed, -110
[  128.779019] xhci_hcd 0000:28:00.0: xHCI host not responding to stop endpoint command.
[  128.795030] xhci_hcd 0000:28:00.0: Host halt failed, -110
[  128.795031] xhci_hcd 0000:28:00.0: xHCI host controller not responding, assume dead
[  128.795054] xhci_hcd 0000:28:00.0: HC died; cleaning up
[  128.795084] usb 3-1: USB disconnect, device number 2

Is there any hope for this, or do I need to return the card and try another?

EDIT: Well, I am sending the card back and ordering another based on a different chipset. Fingers are crossed.

4
  • 2
    I fought with the VL805 chipset as it is built on my motherboard here. I could not get it to work correctly regardless of what drivers or anything. If I had a drive plugged into it half the time it would not boot into Ubuntu. The sad part is, it worked fine in Windows. I tried absolutely everything I could think of. I ended up disabling the contoller on my board and went with a Rocket Fish (off brand) 02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03). I have not had an issue with it since.
    – Terrance
    Commented Feb 24, 2021 at 19:52
  • @Terrance did you have to leave the onboard USB hardware disabled even with the new card? I need to avoid that :( Commented Feb 24, 2021 at 19:59
  • Yeah I did have to leave it disabled. But that was only the USB 3 ports in my BIOS settings I left disabled because that VL805 chipset did not want to work with Ubuntu. I actually thought that my external USB 3 drive was bad as when I unplugged it from the built on ports Ubuntu booted fine. On a whim I installed the other card, plugged in the drive and it worked fine. The main reason I leave the onboard disabled is that in case I plug something into it I don't want to experience the same no boot to Ubuntu.
    – Terrance
    Commented Feb 24, 2021 at 20:02
  • Remember, this is only because my MB has the VL805 on it. Since yours is on your card that is removeable, there is no reason for you to disable your onboard controllers.
    – Terrance
    Commented Feb 24, 2021 at 20:04

2 Answers 2

1

just disable iommu in bios and add "iommu=soft" in grub commandline

2
  • Interesting proposal. I cannot test this since I have returned the card now, but hopefully anyone else who might find this question could benefit from it! Commented Jun 4, 2021 at 12:57
  • Tried that. From the boot up messages on console it then detects the extern USB 3 HDDs… but kills mouse and keyboard. Commented Dec 18, 2021 at 5:36
0

See your comment, I believe it is an answer, so I will post the answer part as such.

Disable the contoller on your board and go with a Rocket Fish (off brand) 02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)

3
  • 1
    Well, disabling the onboard controllers is not an option, I got an additional card because I need more USB ports, but a splitter is not suitable, as it would bottleneck the bandwidth. Commented Feb 24, 2021 at 19:58
  • 1
    Well, that is better. That certainly worked. I am glad that what you did with the card helped!
    – Logan
    Commented Feb 24, 2021 at 19:59
  • I think I caused confusion. Nothing has been tried, and the card is not working. I'm just observing that disabling the existing controllers is not viable-I need them to working too. Commented Feb 24, 2021 at 23:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .