7

I tried to install ProtonVPN on my Ubtuntu 20.10 via official ProtonVPN documentation. After installation, I noticed ethernet icon appearing on top-right but internet was not working. I then uninstalled protonVPN but still internet is not working even WIFI is connected. There's still ethernet icon top-right. I tried using my phone's internet via USB tethering, I was able to connect tethring but internet was still not wotking.

How can I solve this?

2
  • 1
    Recommend you to seek for help from Proton official support as well
    – Emil
    Feb 24, 2021 at 17:46
  • VPNs, in general, mess with IP routing. Look at ip route show. You should have a "default" route pointing to your router.
    – waltinator
    Feb 24, 2021 at 20:44

3 Answers 3

14

This question is pretty old but I had the exact same problem with the exact same distro so I'll answer with how I solved it after uninstalling protonvpn. By running

nmcli device

I found out I had two extra connections that had remained there and the system was trying to route through them, so after identifying them I simply did

sudo nmcli connection delete pvpn-killswitch
sudo nmcli connection delete pvpn-ipv6leak-protection

After that rebooting solved everything.

Also, note that there is also a workaround to use protonvpn service if after the installation internet stopped working. Simply run:

nmcli connection show --active

Then,

nmcli connection delete [connection name]

In my case the code was:

nmcli connection delete pvpn-ipv6leak-protection

After that, just open protonvpn and connect normally.

3
  • solved it by just sudo nmcli connection delete pvpn-ipv6leak-protection Aug 18, 2021 at 14:28
  • This solved my issue. I think there's a bug with protonvpn
    – asaf92
    Aug 20, 2021 at 10:41
  • This solved it for me too.
    – nabla
    Dec 4, 2021 at 14:42
1

The official Protonvpn installation page is giving the same solution with a few extras: Remove any leftover files:

rm -rf ~/.cache/protonvpn

And

rm -rf ~/.config/protonvpn
1

I do not know for sure that my problem was related yo yours, but after installing ProtonVPN and connecting to a server, my connection was refused when connecting to any website, despite the fact that I could ping. Well, in my case, I did

protonvpn-cli ks --off

This disables the KillSwitch function. There is a related information here too: https://stackoverflow.com/questions/68229831/protonvpn-broke-my-machine-after-upgrade-to-linux-cli-version-3

and after this I could connect to any server and it could allow me to connect to any web place. Dunno if this is default setup that should be avoided. Never experienced this before.

1
  • You could explain that your command disables the kill switch like this post explains it. Also you could try sudo nmcli connection delete pvpn-ipv6leak-protection which is an answer in the same link earlier. Jan 1 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.