0

I've just installed apache and mysql on my system and a copy of Wordpress from my production server.

When I access the website, the home page loads perfectly, but if I click any other link with the website I get:

Not Found The requested URL was not found on this server.

I've searched high and low online and most of these posts are regarding permalinks, but this problem affects all pages within my site. I tried updating the apache2.conf file to AllowOverride All in each 3 sections, as some suggested this could be the cause but this has not fixed it:

1
  • Sounds like you're missing .htaccess in the web root, or mod_rewrite is not enabled. – user1091774 Feb 24 at 12:09
0

Finally found a way to fix this:

sudo service apache2 restart
sudo a2enmod rewrite
sudo systemctl restart apache2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.