0

when trying to change the ownership of a directory i get the error:

chown: changing ownership of '/home/tadpoles': Operation not permitted

I even get the above message when i do sudo -s and run it as root.

Here is the command i try to run:

sudo chown toadmanager /home/tadpoles

Also, here is the perms of the directory when i run ls -l: (SharedFolder is in the directory and it also cannot be modified)

total 32
drwxr-xr-x 2 root root 32768 Feb 16 12:23 SharedFolder

I am fairly new to ubuntu and linux in general so any help is appreciated, i also already looked up some other guides and chgrp did not work either. I should also mention that this directory is on a different drive which is mounted to /home/tadpoles and the file system is vfat

3
  • 1
    You should not be running Linux partitions on a vfat format. That applies to EFI partitions for booting. Chown and chmod permission commands work on ext4 format, which is what you should be running Linux on. – Paul Benson Feb 23 at 23:15
  • See also Why chown command can't take effect? – steeldriver Feb 23 at 23:28
  • @Paul Beson, Incorrectly states not to use fat for an EFI partition to boot from, that is part of the standard it requires that there be fat partition for an EFI boot partition for the machines to boot EFI. A comment on FAT and permission changes is, it does not support permissions. – user1179897 Feb 24 at 3:22
0

If you could run this command and post the output to the original question, it might help.

    cat /etc/passwd | grep toadmanager

If you get no output from the command it means that toadmanager is not a user on your system.

You can search for Users in the Activities panel in Ubuntu 20.04 LTS, unlock the application, and use the green pushbutton to "Add User" for toadmanager.

1
  • Hey thanks for your reply, toadmanager is a sudo user that i can log into. I also have no physical access to the machine, this is all over ssh – Toad Box Feb 24 at 0:41
0

Solved, i had a vfat file system so i went in a reformatted the drive in ext4. Everything works properly now!

Thanks Paul Benson

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.