0

I had issues with my internet connection after upgrading to Ubuntu 20.04.

The current situation is as follows:

  1. If I connect my computer to the main wifi (where all my other devices are connected to), I rarely get a connection. It's spotty, slow and mostly nonexistent.

  2. If I connect to a repeater, I get slightly better connection.

  3. If create a hotspot on my smart phone and connect my computer to it, I get excellent connection.

All my other devices are connected to the main router without problems (smart phones, TV, other laptops). There is only one laptop that I cannot connect and it's the one that has Ubuntu LTS 20.04. Note that I was able to upgrade over the interned from the 18.04 version with no problems.

I read several posts about what I thing are similar problems, but nothing worked. Maybe the solution is to re-install Ubuntu?

########## wireless info START ##########

Report from: 24 Feb 2021 09:13 EST -0500

Booted last: 24 Feb 2021 00:00 EST -0500

Script from: 25 Jan 2020 03:34 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 20.04.2 LTS
Release:    20.04
Codename:   focal

##### kernel ############################

Linux 5.4.0-65-generic #73-Ubuntu SMP Mon Jan 18 17:25:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/rtl8723be.conf line 2: ignoring bad line starting with 'exit'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/rtl8723be.conf line 3: ignoring bad line starting with 'ls'

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    DeviceName: Foxconn WLAN Realtek Sanji RTL8723BE bgn 1x1 + BT 4 LE PCIe+USB NGFF 2230 M.2 WW
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:b006 Realtek Semiconductor Corp. Bluetooth Radio 
Bus 001 Device 003: ID 04f2:b50d Chicony Electronics Co., Ltd HP Truevision HD
Bus 001 Device 005: ID 0bc2:3300 Seagate RSS LLC Desktop         
Bus 001 Device 006: ID 058f:6387 Alcor Micro Corp. Flash Drive
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### secure boot #######################

SecureBoot disabled

##### lsmod #############################

rtl8723be             102400  0
btcoexist             155648  1 rtl8723be
rtl8723_common         24576  1 rtl8723be
rtl_pci                28672  1 rtl8723be
rtlwifi                90112  4 rtl_pci,rtl8723be,btcoexist,rtl8723_common
mac80211              843776  3 rtl_pci,rtl8723be,rtlwifi
hp_wmi                 16384  0
sparse_keymap          16384  1 hp_wmi
wmi_bmof               16384  0
cfg80211              704512  2 rtlwifi,mac80211
libarc4                16384  1 mac80211
wmi                    32768  2 hp_wmi,wmi_bmof

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback <MAC address> brd <MAC address>
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether <MAC 'wlan0' [IF1]> brd <MAC address>
    inet 192.168.0.15/24 brd 192.168.0.255 scope global dynamic noprefixroute wlan0
       valid_lft 42777sec preferred_lft 42777sec
    inet6 fe80::99be:f67c:eb4c:b04e/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

##### iwconfig ##########################

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"0017508204"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: <MAC '0017508204' [AC1]>   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=48/70  Signal level=-62 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1133   Missed beacon:0

##### route #############################

default via 192.168.0.1 dev wlan0 proto dhcp metric 600 
169.254.0.0/16 dev wlan0 scope link metric 1000 
192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.15 metric 600 

##### resolv.conf #######################

[644 root '/etc/resolv.conf']
nameserver 127.0.0.53

##### network managers ##################

Installed:

    NetworkManager

Running:

root         609       1  0 08:22 ?        00:00:04 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/Devices/2
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8723BE PCIe Wireless Network Adapter
GENERAL.DRIVER:                         rtl8723be
GENERAL.DRIVER-VERSION:                 5.4.0-65-generic
GENERAL.FIRMWARE-VERSION:               N/A
GENERAL.HWADDR:                         <MAC 'wlan0' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.IP4-CONNECTIVITY:               4 (full)
GENERAL.IP6-CONNECTIVITY:               3 (limited)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.3/0000:02:00.0/net/wlan0
GENERAL.IP-IFACE:                       wlan0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     0017508204
GENERAL.CON-UUID:                       f493740d-38bd-494f-8d61-562e1aef0549
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/6
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     72 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
CAPABILITIES.SRIOV:                     no
INTERFACE-FLAGS.UP:                     yes
INTERFACE-FLAGS.LOWER-UP:               yes
INTERFACE-FLAGS.CARRIER:                yes
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   no
WIFI-PROPERTIES.MESH:                   yes
WIFI-PROPERTIES.IBSS-RSN:               yes
IP4.ADDRESS[1]:                         192.168.0.15/24
IP4.GATEWAY:                            192.168.0.1
IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh = 192.168.0.1, mt = 600
IP4.ROUTE[2]:                           dst = 192.168.0.0/24, nh = 0.0.0.0, mt = 600
IP4.ROUTE[3]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             24.154.1.68
IP4.DNS[2]:                             24.154.1.34
DHCP4.OPTION[1]:                        dhcp_lease_time = 43200
DHCP4.OPTION[2]:                        domain_name_servers = 24.154.1.68 24.154.1.34
DHCP4.OPTION[3]:                        expiry = 1614218793
DHCP4.OPTION[4]:                        host_name = nuno-HP-Stream-Notebook
DHCP4.OPTION[5]:                        ip_address = 192.168.0.15
DHCP4.OPTION[6]:                        next_server = 192.168.0.1
DHCP4.OPTION[7]:                        requested_broadcast_address = 1
DHCP4.OPTION[8]:                        requested_domain_name = 1
DHCP4.OPTION[9]:                        requested_domain_name_servers = 1
DHCP4.OPTION[10]:                       requested_domain_search = 1
DHCP4.OPTION[11]:                       requested_host_name = 1
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[14]:                       requested_nis_domain = 1
DHCP4.OPTION[15]:                       requested_nis_servers = 1
DHCP4.OPTION[16]:                       requested_ntp_servers = 1
DHCP4.OPTION[17]:                       requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[18]:                       requested_root_path = 1
DHCP4.OPTION[19]:                       requested_routers = 1
DHCP4.OPTION[20]:                       requested_static_routes = 1
DHCP4.OPTION[21]:                       requested_subnet_mask = 1
DHCP4.OPTION[22]:                       requested_time_offset = 1
DHCP4.OPTION[23]:                       requested_wpad = 1
DHCP4.OPTION[24]:                       routers = 192.168.0.1
DHCP4.OPTION[25]:                       subnet_mask = 255.255.255.0
IP6.ADDRESS[1]:                         fe80::99be:f67c:eb4c:b04e/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 600
IP6.ROUTE[2]:                           dst = ff00::/8, nh = ::, mt = 256, table=255
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/6
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   f493740d-38bd-494f-8d61-562e1aef0549 | 0017508204

GENERAL.DEVICE:                         <MAC address>
GENERAL.TYPE:                           bt
GENERAL.NM-TYPE:                        NMDeviceBt
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/Devices/3
GENERAL.VENDOR:                         --
GENERAL.PRODUCT:                        --
GENERAL.DRIVER:                         bluez
GENERAL.DRIVER-VERSION:                 --
GENERAL.FIRMWARE-VERSION:               --
GENERAL.HWADDR:                         <MAC address>
GENERAL.MTU:                            1500
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.IP4-CONNECTIVITY:               1 (none)
GENERAL.IP6-CONNECTIVITY:               1 (none)
GENERAL.UDI:                            /org/bluez/hci0/dev_E8_36_17_05_F6_EB
GENERAL.IP-IFACE:                       --
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
CAPABILITIES.SRIOV:                     no
INTERFACE-FLAGS.UP:                     no
INTERFACE-FLAGS.LOWER-UP:               no
INTERFACE-FLAGS.CARRIER:                no
BLUETOOTH.CAPABILITIES:                 NAP
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/10
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   d85336bd-a5de-4c5f-8386-7ac0611fd5eb | iPhone Network

GENERAL.DEVICE:                         p2p-dev-wlan0
GENERAL.TYPE:                           wifi-p2p
GENERAL.NM-TYPE:                        NMDeviceWifiP2P
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/Devices/4
GENERAL.VENDOR:                         --
GENERAL.PRODUCT:                        --
GENERAL.DRIVER:                         (unknown)
GENERAL.DRIVER-VERSION:                 --
GENERAL.FIRMWARE-VERSION:               --
GENERAL.HWADDR:                         (unknown)
GENERAL.MTU:                            0
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.IP4-CONNECTIVITY:               1 (none)
GENERAL.IP6-CONNECTIVITY:               1 (none)
GENERAL.UDI:                            /virtual/device/placeholder/1
GENERAL.IP-IFACE:                       --
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
CAPABILITIES.SRIOV:                     no
INTERFACE-FLAGS.UP:                     no
INTERFACE-FLAGS.LOWER-UP:               no
INTERFACE-FLAGS.CARRIER:                no
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: --

SSID        BSSID              MODE   CHAN  FREQ      RATE        SIGNAL  BARS  SECURITY   ACTIVE  IN-USE 
0017508204  <MAC '0017508204' [AC1]>  Infra  11    2462 MHz  195 Mbit/s  64      â–‚â–„â–†_  WPA1 WPA2  yes     *      
--          <MAC '' [AC2]>  Infra  11    2462 MHz  65 Mbit/s   40      â–‚â–„__  --         no             

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager config #############

[[/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf]]
[connection]
wifi.powersave = 2

[[/etc/NetworkManager/NetworkManager.conf]]
[main]
plugins=ifupdown,keyfile
[ifupdown]
managed=false
[device]
wifi.scan-rand-mac-address=no

[[/usr/lib/NetworkManager/conf.d/10-dns-resolved.conf]]
[main]
dns=systemd-resolved

[[/usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf]]
[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:gsm,except:type:cdma

[[/usr/lib/NetworkManager/conf.d/20-connectivity-ubuntu.conf]]
[connectivity]
uri=http://connectivity-check.ubuntu.com/

[[/usr/lib/NetworkManager/conf.d/no-mac-addr-change.conf]]
[device-mac-addr-change-wifi]
match-device=driver:rtl8723bs,driver:rtl8189es,driver:r8188eu,driver:8188eu,driver:eagle_sdio,driver:wl
wifi.scan-rand-mac-address=no

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Panera]] (600 root)
[connection] id=Panera | type=802-11-wireless
[802-11-wireless] ssid=Panera | mac-address=<MAC 'wlan0' [IF1]>
[ipv6] method=auto
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/iPhone.nmconnection]] (600 root)
[connection] id=iPhone | type=wifi | permissions=
[wifi] mac-address-blacklist= | ssid=iPhone
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/TP-LINK_Extender_568017]] (600 root)
[connection] id=TP-LINK_Extender_568017 | type=wifi | permissions=user:nuno:;
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=TP-LINK_Extender_568017
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/WLAN_2E8C]] (600 root)
[connection] id=WLAN_2E8C | type=wifi | permissions=user:nuno:;
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=WLAN_2E8C
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/MOVISTAR_3D28]] (600 root)
[connection] id=MOVISTAR_3D28 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=MOVISTAR_3D28
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Thomson048FE5]] (600 root)
[connection] id=Thomson048FE5 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=Thomson048FE5
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/0017508204.nmconnection]] (600 root)
[connection] id=0017508204 | type=wifi | permissions=
[wifi] mac-address-blacklist= | ssid=0017508204
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/CATZNET2G]] (600 root)
[connection] id=CATZNET2G | type=wifi | permissions=user:nuno:;
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=CATZNET2G
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/SRU-Guest]] (600 root)
[connection] id=SRU-Guest | type=wifi | permissions=user:nuno:;
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=SRU-Guest
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/ANNE]] (600 root)
[connection] id=ANNE | type=wifi | permissions=user:nuno:;
[wifi] mac-address=<MAC 'wlan0' [IF1]> | mac-address-blacklist= | ssid=ANNE
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

##### iw reg get ########################

Region: America/New_York (based on set time zone)

global
country US: DFS-FCC
    (2400 - 2472 @ 40), (N/A, 30), (N/A)
    (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
    (5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
    (5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
    (5730 - 5850 @ 80), (N/A, 30), (N/A)
    (57240 - 71000 @ 2160), (N/A, 40), (N/A)

##### iwlist channels ###################

lo        no frequency information.

wlan0     11 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Current Frequency:2.462 GHz (Channel 11)

##### iwlist scan #######################

lo        Interface doesn't support scanning.

Channel occupancy:

      2   APs on   Frequency:2.462 GHz (Channel 11)

wlan0     Scan completed :
          Cell 01 - Address: <MAC '0017508204' [AC1]>
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    ESSID:"0017508204"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000026fc3935180
                    Extra: Last beacon: 128ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: <MAC '' [AC2]>
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=30/70  Signal level=-80 dBm  
                    Encryption key:off
                    ESSID:""
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000026fc391c142
                    Extra: Last beacon: 256ms ago

##### module infos ######################

[rtl8723be]
filename:       /lib/modules/5.4.0-65-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
retpoline:      Y
intree:         Y
name:           rtl8723be
vermagic:       5.4.0-65-generic SMP mod_unload 
parm:           swenc:Set to 1 for software crypto (default 0)
parm:           ips:Set to 0 to not use link power save (default 1)
parm:           swlps:Set to 1 to use SW control power save (default 0)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
parm:           aspm:Set to 1 to enable ASPM (default 1)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)

[rtl8723_common]
filename:       /lib/modules/5.4.0-65-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko
description:    Realtek RTL8723AE/RTL8723BE 802.11n PCI wireless common routines
license:        GPL
depends:        rtlwifi
retpoline:      Y
intree:         Y
name:           rtl8723_common
vermagic:       5.4.0-65-generic SMP mod_unload 

[rtl_pci]
filename:       /lib/modules/5.4.0-65-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
depends:        mac80211,rtlwifi
retpoline:      Y
intree:         Y
name:           rtl_pci
vermagic:       5.4.0-65-generic SMP mod_unload 

[rtlwifi]
filename:       /lib/modules/5.4.0-65-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
depends:        mac80211,cfg80211
retpoline:      Y
intree:         Y
name:           rtlwifi
vermagic:       5.4.0-65-generic SMP mod_unload 

[mac80211]
filename:       /lib/modules/5.4.0-65-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
depends:        cfg80211,libarc4
retpoline:      Y
intree:         Y
name:           mac80211
vermagic:       5.4.0-65-generic SMP mod_unload 
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/5.4.0-65-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
depends:        
retpoline:      Y
intree:         Y
name:           cfg80211
vermagic:       5.4.0-65-generic SMP mod_unload 
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[rtl8723be]
ant_sel: 0
aspm: 1
debug_level: 0
debug_mask: 0
disable_watchdog: N
fwlps: Y
ips: Y
msi: N
swenc: N
swlps: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp

##### modprobe options ##################

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/rtl8723be.conf]
exit
ls

##### rc.local ##########################

grep: /etc/rc.local: No such file or directory

##### pm-utils ##########################

[/etc/pm/sleep.d/config] (644 root)
SUSPEND_MODULES= "RTL8723"

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x10ec:0xb723 (rtl8723be)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF1]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[   17.711737] wlan0: authenticate with <MAC '0017508204' [AC1]>
[   17.729467] wlan0: send auth to <MAC '0017508204' [AC1]> (try 1/3)
[   17.732002] wlan0: authenticated
[   17.738312] wlan0: associate with <MAC '0017508204' [AC1]> (try 1/3)
[   17.765638] wlan0: RX AssocResp from <MAC '0017508204' [AC1]> (capab=0x431 status=0 aid=3)
[   17.765918] wlan0: associated
[   18.022633] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  276.690542] wlan0: deauthenticating from <MAC '0017508204' [AC1]> by local choice (Reason: 3=DEAUTH_LEAVING)
[  315.151677] wlan0: authenticate with <MAC address>
[  315.164251] wlan0: send auth to <MAC address> (try 1/3)
[  315.224214] wlan0: authenticated
[  315.227974] wlan0: associate with <MAC address> (try 1/3)
[  315.234425] wlan0: RX AssocResp from <MAC address> (capab=0x431 status=0 aid=1)
[  315.234758] wlan0: associated
[  315.458559] wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by <MAC address>
[  325.238952] wlan0: deauthenticating from <MAC address> by local choice (Reason: 3=DEAUTH_LEAVING)
[  326.293183] wlan0: authenticate with <MAC address>
[  326.316842] wlan0: send auth to <MAC address> (try 1/3)
[  326.321809] wlan0: authenticated
[  326.331487] wlan0: associate with <MAC address> (try 1/3)
[  326.369624] wlan0: RX AssocResp from <MAC address> (capab=0x431 status=0 aid=1)
[  326.369911] wlan0: associated
[  326.396211] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  326.620152] wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by <MAC address>
[ 2653.982347] wlan0: deauthenticating from <MAC address> by local choice (Reason: 3=DEAUTH_LEAVING)
[ 2654.523827] wlan0: authenticate with <MAC '0017508204' [AC1]>
[ 2655.032388] wlan0: send auth to <MAC '0017508204' [AC1]> (try 1/3)
[ 2655.034529] wlan0: authenticated
[ 2655.036442] wlan0: associate with <MAC '0017508204' [AC1]> (try 1/3)
[ 2655.042752] wlan0: RX AssocResp from <MAC '0017508204' [AC1]> (capab=0x431 status=0 aid=1)
[ 2655.043005] wlan0: associated
[ 2655.091078] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

########## wireless info END ############
0
2

In your paste, we see:

libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/rtl8723be.conf line 2: ignoring bad line starting with 'exit'

There is nothing helpful in the file; let's remove it:

sudo rm /etc/modprobe.d/rtl8723be.conf 

Next, please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I recommend a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Reboot and tell us if there is any improvement.

8
  • Thank you again for your support. I was able to remove the configuration file as you suggested. Can the problem be the driver for this Realtek equipment? Router security, it is set to WPA & WPA2 Personal. It does not have a WPA-AES option. Other options are WEP, LEAP, Dynamic WEP and WPA3. My regulatory domain is set to the US (correct), so I made no changes. Currently I’ve been playing between connecting via my router, or a personal hotspot created by my phone. The phone seems to be working better. When I’m connected via the router, I end up loosing the connection after some time. Feb 24 '21 at 19:06
  • What is the make and model of the router. I'd like to look up its manual on line. TKIP is inserure and must not be used. I am surrised that any router doesn't allow you to deselect it.
    – chili555
    Feb 24 '21 at 20:55
  • If by router you mean the modem, it's a Arris, model DG2470A [arris.secure.force.com/consumers/articles/User_Guide/…. Feb 24 '21 at 21:18
  • UPDATE: This morning during the process of updating the software, I got the following message: [paste.ubuntu.com/p/ZkDMxdmDSz]. Does it help? Feb 25 '21 at 12:14
  • It means that dkms cannot successfully compile a driver for an rtl8188ee device. According to your previous paste, that's not at all what you have. I suggest that we remove it and all other unneeded dkms drivers. Please let me see a paste of: sudo dkms status
    – chili555
    Feb 25 '21 at 16:11
0

Run

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=2"

and reboot.

If that doesn't help, try ant_sel=1.

This will set the driver to use the correct antenna.

-1

Gave up and installed a USB wifi device. Read that the main problem with this laptop is the low range of the wifi internal antenna. This resolved the problem.

6
  • 3
    It is not low range. You were using a wrong antenna. It is fixable
    – Pilot6
    Nov 8 '21 at 18:52
  • What do you mean by "wrong antenna"? I have read several threads and many pointed out that the driver for this antenna was never upgraded. It is also true that I had smooth internet connection prior to upgrading Ubuntu. If this is fixable, I'm really interested in knowing how. Nov 10 '21 at 13:57
  • I mean that linux can't detect which antenna is physically connected if there is one antenna in the laptop. It can be easily fixed by setting a parameter.
    – Pilot6
    Nov 10 '21 at 13:58
  • I guess I don't know enough about this to agree or disagree with you. What I can tell you is that I tried everything I found, for months, and nothing worked. I installed this simple USB type antenna and puff... problem solved. If this can be fixed, at least I'll have an additional USB connection available : ) Nov 10 '21 at 14:05
  • I wrote an answer about how to fix it.
    – Pilot6
    Nov 10 '21 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.